Comodo Dragon v57.0.2987.92 is now available for download.

Hello everyone,

We’re very pleased to announce the release of Comodo Dragon v57.0.2987.92.

Release notes:

New features

  • Video support reliability improvements.
  • Updated code to Chromium 57.x codebase.
  • Sign into Dragon fixed.

Comodo Dragon v57.0.2987.92 can be downloaded from:

File checksums:
MD5: fcbb09db3151b10e1cb457c9e3ec2fac
SHA-1: 69845fa1cf349d9505236956cd619c374c38ab2f

The Comodo Browser Team

Mod edit: fixed download link. FT

The in-browser update is NOT working for me, no matter what i do. It just don’t wanna get around to make a proper update.

The solution here was to DL & Update with the official setup.

Hi All,

We have some sync issues we’re looking into.

Congrats with the new release. :slight_smile:

Could you elaborate on what the “Video support reliability improvements” are?

For those who are having problems with the update not properly installing please try the following workaround by captainsticks:

Does anyone having issues with packaged apps since the update?

I’m having issues on two systems - packaged app display blank UI upon launch. Before the v.57 installation it worked fine…

Can you provide an example? Also package apps were discontinued by Google, do you mean Chrome Apps instead?

Yes, I do mean “chrome apps”.

The one I’m having issues with is Signal Desktop (GitHub - signalapp/Signal-Desktop: A private messenger for Windows, macOS, and Linux.).

After launching the application, it opens, but the window is black (see attachment). Seems like it’s only the visuals that are affected, since the mouse cursor changes depending on the location within the window (expected), so it seem to be somewhat alive.

The only change occurred before the bug surfaced is Dragon update to v.57. (same app version). As mentioned before I see this behavior on multiple systems after the browser update.

Another thing - there is some weird shit going on with TLS verification: dragon reports “not secure” for seemingly valid certificate (while at the same time, just displaying the page, without all the blocking warnings).

Example: (see screenshot)
other browsers report this page as secure (firefox 53.0.2, vivaldi 1.9)

Checked for an internal update this morning and still get a message stating ’ downloaded file is not properly signed ’ had to manually download and upgrade ?

Hi guys!
First of all, i want to thank you for this awesome and secure browser. Comodo Dragon v55 had WebRTC on|off option but in this release it has gone or disappeared. Now i have to use some extensions for stop this leakage. Please bring it back this option. :slight_smile:


When checking IP/DNS settings, the link to disable WebRTC takes you to a page stating this setting cannot be found

Since my CD was automatically upgraded to the latest version last night, I encounter the problem occasionally that some hyperlinks in some webpages take forever to be loaded if I attempt to open the hyperlinks in a new tab by clicking the middle mouse button. The new tab gets stuck. Refresh the tab doesn’t help. However, if I just type the url address in a new tab, the page is loaded perfectly fine.

This problem doesn’t occur very often, but it always happens when I visit

Middle-clicking any links on this page is fine for the first time. But any further middle-clicks will lead to stuck tabs.

The latest version of Chrome doesn’t have this problem.

Sorry for my bad english. In new Comodo i have some bugs (some apps have black window. Some videos gets freeze, but sound works. Some new tabs get stuck ) when hardware acceleration turning on. When turning off acceleration bugs disappear.

Thanks for the information. I also have the same problem that new tabs get stuck sometimes. Turning off hardware acceleration does solve the problem.

Can confirm. Disabling hardware acceleration solves the issue I mentioned having with black UI of Chrome Apps (Signal Desktop)

When watching YouTube 1080p 60fps video, browser has a high percentage of dropped frames. I like to use the extension Magic Actions for YouTube because of all of the available player sizes. Default, theater, cinema, what I call full-browser and last but not least, full-screen. The player size that I’m seeing Dragon have a problem with is the ‘full-browser’ which is the size I usually use. When watching 1080p 60fps video I’m seeing an average of 10% dropped frames which is significantly higher than the previous version of Dragon. I doubt if v55 had 1% dropped frames using any player size. Played the same video three different times and each time the dropped frames were around 10% in Comodo Dragon when using the full-browser player size. I usually use a chromium browser to get caught up on my YouTube subscriptions because of the full-browser player size with Magic Actions. In FF I usually use YouTube High Definition because it works with embedded video but I disabled it to use Magic Actions, which is also installed. CPU usage is doubled in Dragon compared to what Chrome, Vivaldi and FF use. And GPU load is half of what the other browsers use. “Hardware acceleration” is enabled in all browsers. Dragon, Chrome and Vivaldi, use the same settings, flags and extensions. The video used is from Erica Griffin because I know all of her 1080p videos are 60fps. Video was played for 2 minutes. BlackBerry KEYone Unboxing: QUESTIONS ANYONE? - YouTube

Comodo Dragon, cpu usage percentage is mid 40’s, gpu load percentage mid 20’s. 750 dropped frames.
Chrome v58 x64, cpu usage mid 20’s, gpu load mid 40’s. 8 dropped frames.
Vivaldi x64 w/58 base, cpu usage mid 20’s, gpu load mid 40’s. 6 dropped frames.
Firefox v52 ESR x64, cpu usage in the teens, gpu load high 40’s. 0 dropped frames.

Running: Win7 Pro x64, Core i-5 @ 3.2-3.4GHz, 16GB ram, Sandisk Extreme Pro ssd, GTX 750Ti SC.

Previous version (55?) cured the problem with videos on facebook and twitter…wonderful! Now with this latest version the problems are back AND I’m having conflicts playing some flash video clips.
Is there any way to dump this latest version and revert to the previous version please? I was SOO happy for a week or so :frowning:
Also the Comodo Dragon start icon has disappeared from my desk top, so I have to open from programme files! :open_mouth:


I noticed another issue with ‘use hardware acceleration when available’ being enabled, videos on will show a black screen but you can still hear the video being played. Turning off hardware acceleration you can see videos normally.

For all people looking for a download location of Dragaon v 52 please check Filepuma: Comodo Dragon Internet Browser (32bit) Download - Fast and versatile Internet Browser based on Chromium .

I would like to encourage everybody to keep local copies of installers of important programs. HD space is not the issue. 88) 8)