Comodo Dragon v119.0.6045.200 32&64-bit are now available for download

Hello All,

We are pleased to announce the release of Comodo Dragon v119.0.6045.200 32&64-bit are now available.

New Features:
Updated to Chromium v119 codebase.

Known bugs:
*Chrome Sync not working

Bugs fixed:
*After installation a shortcut is created on the taskbar on Windows 10
*Custom extensions are not available after CD Portable folder is copied to a different location

Comodo Dragon v119


Live Update URL:

md5: 99bd9f0fff5630626d619353929f4e41
SHA1: c3388894727ea1e2cb0c39f04097a3412eed965d
SHA-256: 0706ae2204bf99e949efe3ac7f59cd38071a3d8ba2059e3aa200ec2787b837ad

Live Update URL:

md5: 8b3ad91fa0980054f52d333c841d8211
SHA1: 02129e828e20b0140340c682183064e62992bbbf
SHA-256: c602ba77df9b729c76f8e46cf85481950971fcbeddd76a3a96479a29ffa7862a

The update will be pushed out to existing users within the next few hours. Please use the browser and give us your feedback.

The Comodo Browser Team

1 Like

Nice one, can’t wait to try out the new version and only a week behind chrome’s latest release.

Hi @EricCryptid,

Thank you for the feedback and thank your for being an active user.

Best regards,
Comodo Dragon Team.

Hi, there!

After the last update(Comodo Dragon v119.0.6045.200), none of the VPNs are working for me.
I tried with different browser(Microsoft Bing) and no problem with VPN.They work fine.
Without VPN, comodo dragon also works fine. But after connect with VPN, i can’t open any website.
I received a connection error or a time out error. (“Err_Timed_Out” or “Connection is not secure”)
I did everything; delete my browser data, repair the hosts file, reset comodo dragon, reinstall, update
vpns… Tried with three different VPN (F-Secure Freedome, NordVPN, Windscribe) they work with
other browsers but not Comodo Dragon. My Windows 10 is update.

This is all started after the last update so i don’t know… Any thoughts?

Can you check if you have use Secure DNS enabled? That’s Comodo’s DNS servers and that might be conflicting with the VPN though I’m not 100% sure it’s the cause.

Thanks for the quick reply!!!

I disabled Secure DNS, nothing changed. Problem remains…

Are you running Comodo Dragon in Virtual Mode?
What security products are you using?
Which VPN are you using?

Just trying to narrow down the issue so @cosmin.dragon with more expertise can assist.


2.I don’t use any.
3.F-Secure Freedome VPN, Nord VPN, Windscribe. I tried all of them and none of them works.
They work fine with other browsers. Only Comodo has problem. VPNs are connecting but
Comodo doesn’t open web pages.(“err_timed_out”)

Hi @arranca,

Please check if you have any DNS set in Control Panel.
You can follow the steps below:

  1. Go to Control Panel > Network and Internet > Network and Sharing Centre > Change adapter settings

  2. Right click on your network adapter and press Properties

  3. Double click on Internet Protocol Version 4 (TCP / IPv4)

  4. Select “Obtain an IP adress automatically” and “Obtain DNS server address automatically”

LE: Please also enable “Parallel downloading” in the flags page (chrome://flags/).

Please check and let us know if this works.

Kind regards,
Comodo Dragon Team.

1 Like

Thanks again for the reply!
I tried but no change. I don’t think my internet settings are the problem. Comodo (Or other browsers)
works fine When VPN is off. Recently i realized free vpn extensions are working fine also with Comodo. I downloaded couple of vpn extensions (free or trial) and they all work fine.
Problem is my seperate VPN that i always used.(F - Secure Freedome VPN) I uninstall and reinstall the program over and over (I used ccleaner), update it or reinstall older versions… Not working!
(It works with other browsers, i can use it with Bing or i can download Torrent. There is no problem with F-Secure) But after Comodo update it’s just not opening web pages.
Some pages are opening but very slow(constantly loading) and others just “err_timed_out”
I think F-Secure and Comodo are crashing some way but i couldn’t figure it out what causes the problem!
One more thing, right before Comodo update, i used CCleaner without any settings (Clean my cache…etc) Maybe it erased something but after that i reinstalled Comodo Dragon.(Repair) Not worked.
This time i will remove Comodo completely and reinstall again, see if it works!

Edit: I did remove Comodo Dragon and reinstall it. Problem remains… I don’t know what else
i can do without knowing what causes it.

Edit 2: After the last reinstall, Comodo started to open some pages immediately(Google, Indiewire), but the pages never finish loading. Other pages still don’t open at all(“err_timed_out”)(This is with
F-Secure turned on. No problem with it off.)

Hi @arranca,

We will investigate and come back as soon as possible with a solution for your issue.
We are sorry for the inconvenience.

Best regards,
The Comodo Browser Team.

1 Like

Hi @arranca,

Can you please try again on Comodo Dragon v120 Beta and let us know if the issue still occurs for you?

We did not encounter the issue on this version.

The Comodo Browser Team.

1 Like

It worked!
After installing Comodo Dragon v120 Beta, I can use F-Secure Freedom without any problems.
Thank you so much for finding a solution in such a short time.

1 Like

Hi @arranca,

Thank you for being an active user!
We are glad that we were able to fix your issue.

Best regards,
The Comodo Browser Team.