Comodo Dragon stops loading new pages after 5 minutes

Firstly sorry for the long post.

I am having trouble with Comodo Dragon running on the most recent updates of Windows 10.

I have several browsers installed for times when one of them fail. I use Comodo Dragon mostly then Comodo Ice Dragon for some websites and have Google Chrome as a backup.

For some time now, with different different Windows 10 updates Comodo Dragon, Comodo Ice Dragon and Google Chrome have had the same problem which is that they all stop responding after about 5 or 10 minutes. I haven’t tried Firefox to see if it has the same issue but I presume it would.

I can start the browser, open pages and surf the net fine with no problems for 5 or 10 minutes but after that if I open a new page like the google search page or click on a link in an already open page to open a new tab or simply open a new Blank page all I get is a grey page and with the exception of the Blank page an icon of an unhappy face on the tab for that page.

I have to shutdown the browser and restart it then go to the history to open the previous tabs to get back to where I was so I can continue.

No other internet based program is affected by this disconnection problem, I can run things like steam, Team Speak, Discord, online games etc. with no interruption, it’s only non Microsoft browsers that are affected, or at least I haven’t noticed it with IE or Edge but I don’t use them unless I have to.

I have deleted the user profile and created a new one, but that didn’t stop it from happening.

I use Comodo Internet Security and have the windows firewall and antivirus turned off.

I presume that CIS isn’t the problem as the browser will work fine and can download for 5 or 10 minutes.

It seems like there is some sort of timer that disables a browser connection after a period of time.

Comodo Dragon has already stopped working 3 times while I have tried finding a solution in the forum.

The only other option that I can think of to fix the problem is to create another partition and a fresh installation of Windows but that might not work either.

Any suggestions on how to fix this problem will be appreciated.

PS. I just tried to open a new Blank page after typing this post but before posting it and the Blank page is grey.

I still haven’t closed the browser, I was able to post the previous message, log back into the forum after posting it, add this post, yet it is impossible to navigate to another site, open a new Google search page, copy the web address and paste it in a new page or open a new or blank page until the browser is restarted.

But it is possible to use an already open Google search page to search for something, or even duplicate the search page and search for anything on the new search page but I just can’t open any link that is returned by the search.

It seems that if I stay on the Google site I can go anywhere on that site, same for the Comodo site, but if I go to a new site the browser stops.

This could be that your version of Flash is out of date. Can you check for updates on all your browsers and check the CIS firewall logs for anything being blocked. Are you using IPv6 filtering in CIS? You may need to add some additional firewall rules if that’s the case.