Comodo Dragon issue

whats up , now everytime i load dragon i get this “an additional plug-in is required to display some elements on this page” and when i click download it still comes up everytime i load dragon again, guess I will start useing fire fox now

Hi Biker,
Can you give us some more info please?
What URL this is happening on or what plug-in is required??

I’m getting the same on and a couple of others. Click on the “Install plugin …” button and the yellow bar goes away. No indication what plugin is involved

Do you have the latest flash player plugin found here?
The site in question does use flash.

Hi - thanks for quick reply. No joy I’m afraid. I also tried from here, where it says that Flash is built in but disabled. I checked in “about:plugins” and Flash is enabled. The File Hippo site also produced the plugin banner by the way (and the Guardian site I linked to the banner appears away from the main page).

This issue only came about after the CD update I did yesterday.

Thanks for your time


Just reinstalled CD using the “repair” option. The Guardian sites seem to be clear now though the FileHippo site wasn’t ??? I’ve cleared the cache etc

Spoke too soon. What is an “incubator” version of Adobe Flash? That is what is showing up on inline videos [on the BBC for instance]. Other pages just sday no flash installed. So I uninstalled everything and did a reinstall of DC and Flash. Still no luck. Google Chrome working ok btw.

Spoke too soon there too. GC doing the same thing

I am not sure what is happening, I can’t reproduce the issue here sorry.
I will ask for help from the other Mods and see if anyone has some ideas.
Regarding the Incubator version it is some development program, some information found here and here.

Thanks Captain. I only know about the Incubator thing because videos played (on the BBC site) had, in the bottom right corner, “Adobe Flash player version blah blah incubator version”. Have uninstalled Flash and Shockwave and reinstalled. Again. On Google Chrome at the moment and all OK … wish I hadn’t said that! ;D Will try again later on CD.

Thanks again for your time.


Doesn’t’ seem to reproduce here either.
Can you post a screenshot of the page having the issue with full URL visible and one of about:plugins

Hi. Sorry. I can’t because situation has not reappeared. I’m sorry I can’t be more precise about it but completely uninstalling/reinstalling Flash and Shockwave and Google Chrome and CD seems to have done the job.

Thanks for looking at the issue


Everything works for me fine. With the Flashplayer.

I installed the lastest Non IE Flashplayer Beta 1 and Comodo Dragon runs smooth



I have been using CD for about a year now and it’s my favorite browser, now for some reason it simply will not open…I have tried uninstalling, reinstalling, everything I can possibly think of and nothing is working…HELP