Comodo Dragon 45 Portable can't update.


When I tried to update Comodo Dragon portable, I went to menu >> about (chrome://help), then with the message “A new version of Comodo Dragon is available” I clicked on Download. OK, I could see that it was downloading. After that it showed a message: “This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel.” so I could not update it. I am using Windows 10.

I Solved by downloading and reinstalling Comodo Dragon 46 manually. After downloaded 46, install as portable, I went to menu >> about (chrome://help), it showed me So I clicked on Download and now it worked without that message, updating to

OK, it updated to 46, but Comodo Dragon would be good update directly…

I was thinking about history, my personal settings, etc but when it is connected on Google account it is all restored.

I just create this post case some one face the same (specially that message).


Thank you. :slight_smile: