Comodo does no longer start


this morning the firewall taskbar icon was no longer there, therefore I tried to click “firewall” from the program list, but nothing happened.
Windows security center says that comodo is up and running, however, the program is not among the running processes if I go to CTRL+ATL+DLT.

What’s going on? ???


BTW, I think I am using the latest version, 3.8.64094.467

OK, I clicked the cfpupdat.exe file and performed an update, now, when I go to properties of cfp.exe file/version I have:
However, no change at all, still no icon, no Comodo in the running processes.

Hi Metallo

This has happened to me a couple of times in the last few days. I’m not sure what is causing it but it is good to bring it to the attention of others and see if it is widespread and if it is a bug or not.

You can get the icon back by clicking the desktop icon or the link on your start menu, but this is not the way it should be done.



I wish it would be as you say, but the problem here is that Comodo is not running at all, therefore even by clicking the desktop icon nothing happens.

It could be a bug due to the latest update, I’d like to uninstall and intall again but don’t know how to save my settings and rules, given that I cannot access the application.
I tried via the registry but the necessary keys are not shown probably because the application is not running.

Do you know where rules and settings are stored in the Comodo installation folder?


PS: I changed the title in order to draw more attention.

Hi Metallo

The latest version is .477

You can save you configuration by opening the GUI if you can ever get it open and go to miscellaneous - manage my configurations - and click export. It will ask you what you want to name it and where to put it. Then when you re-install you can import the saved config.



I’m afraid your answer doesn’t help, as I said, I cannot open the GUI.

Isn’t there a way to save from the firewall folder or repair folder?


You can go to Programs - Comodo - Comodo internet security - choose the config you are using and save it from there. Later you can replace the new install config with this one - probably have to do it in safe mode otherwise it will be in use, but haven’t tried yet.


OK, here’s the situation:

I decided to uninstall Comodo and do a new installation from scratch but:

Uninstall doesn’t work either, neither from control panel nor from Comodo.
Therefore I downloaded a script I found in this forum,, and tried to do it using the c:\fwconfig.exe -uninstalln script, it didn’t work :o
So, I did a manual uninstall process, I manage to remove about 13500 registry keys, but the 15 keys below failed to be removed.

I downloaded the CIS and tried to install it, at the end of the installation I got an icon on desktop, clicked on that, same story, no sign of life.
Went into registry again, didn’t find any additional registry key generated by the new installation process, I only found the old keys (below) that I cannot remove, not even in Safe Mode.

Now, I have a True Image Backup of 3 months ago, but that’s not a great deal, given that not much changed in my C:\ drive, so I can still go that way to solve this mess.
However, if anybody help me to remove the keys below, I think I still could try a new installation.

Hope you can help! :wink:


HKEY_LOCAL_MACHINE\system\currentcontrolset\enum\root\legacy_inspect\0000\DeviceDesc : Comodo Network Engine
HKEY_LOCAL_MACHINE\system\currentcontrolset\enum\root\legacy_cmdmon\0000\DeviceDesc : Comodo Application Engine
HKEY_LOCAL_MACHINE\system\currentcontrolset\enum\root\legacy_cmdhlp\0000\DeviceDesc : COMODO Firewall Pro Helper Driver
HKEY_LOCAL_MACHINE\system\currentcontrolset\enum\root\legacy_cmdguard\0000\DeviceDesc : COMODO Firewall Pro Sandbox Driver
HKEY_LOCAL_MACHINE\system\currentcontrolset\enum\root\legacy_cmdagent\0000\DeviceDesc : Comodo Application Agent
HKEY_LOCAL_MACHINE\system\controlset003\enum\root\legacy_inspect\0000\DeviceDesc : Comodo Network Engine
HKEY_LOCAL_MACHINE\system\controlset003\enum\root\legacy_cmdmon\0000\DeviceDesc : Comodo Application Engine
HKEY_LOCAL_MACHINE\system\controlset003\enum\root\legacy_cmdhlp\0000\DeviceDesc : COMODO Firewall Pro Helper Driver
HKEY_LOCAL_MACHINE\system\controlset003\enum\root\legacy_cmdguard\0000\DeviceDesc : COMODO Firewall Pro Sandbox Driver
HKEY_LOCAL_MACHINE\system\controlset003\enum\root\legacy_cmdagent\0000\DeviceDesc : Comodo Application Agent
HKEY_LOCAL_MACHINE\system\controlset001\enum\root\legacy_inspect\0000\DeviceDesc : Comodo Network Engine
HKEY_LOCAL_MACHINE\system\controlset001\enum\root\legacy_cmdmon\0000\DeviceDesc : Comodo Application Engine
HKEY_LOCAL_MACHINE\system\controlset001\enum\root\legacy_cmdhlp\0000\DeviceDesc : COMODO Firewall Pro Helper Driver
HKEY_LOCAL_MACHINE\system\controlset001\enum\root\legacy_cmdguard\0000\DeviceDesc : COMODO Firewall Pro Sandbox Driver
HKEY_LOCAL_MACHINE\system\controlset001\enum\root\legacy_cmdagent\0000\DeviceDesc : Comodo Application Agent

This is an update.

I managed to delete the registry keys by allowing full control permission ;D
Did the CIS installation again, but… no sign of life, the installation if quick and then asks reboot to fiinalize it, once you reboot and click the CIS icon on desktop, nothing happens, even trying to click uninstall, nothing happens.

Check the registry again, here the keys created by the new “installation”:

HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\menuorder\start menu\programs\comodo{KEY} : {KEY}
HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\menuorder\start menu\programs\comodo\COMODO Internet Security{KEY} : {KEY}
HKEY_CURRENT_USER\software\microsoft\windows\shellnoroam\muicache\C:\DOCUME~1\AD\LOCALS~1\Temp\WZSE0.TMP\CIS_Setup_3.8.65951.477_XP_Vista_x32.exe : COMODO Internet Security Installer
HKEY_CURRENT_USER\software\microsoft\windows\shellnoroam\muicache\C:\Program Files\COMODO\COMODO Internet Security\cfp.exe : COMODO Internet Security
HKEY_CURRENT_USER\software\microsoft\windows\shellnoroam\muicache\C:\Program Files\COMODO\COMODO Internet Security\cfpconfg.exe : COMODO Internet Security
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security\Contact : support[at]
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security\DisplayName : COMODO Internet Security
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security\Publisher : COMODO
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security\Comments : A product from COMODO.
HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\uninstall\comodo internet security\UninstallString : C:\Program Files\COMODO\COMODO Internet Security\cfpconfg.exe -u
HKEY_LOCAL_MACHINE\software\comodogroup{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\CDI{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1\Product Name : COMODO Internet Security
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1\InstallProductPath : C:\Program Files\COMODO\COMODO Internet Security
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1\Shortcuts{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1\Shortcuts\1{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\CDI\1\Shortcuts\1\RelativeFol : \COMODO\COMODO Internet Security
HKEY_LOCAL_MACHINE\software\comodogroup\cdi\1\shortcuts\3{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\cdi\1\shortcuts\3\ShortcutName : COMODO Internet Security
HKEY_LOCAL_MACHINE\software\comodogroup\cdi\1\shortcuts\2{KEY} : {KEY}
HKEY_LOCAL_MACHINE\software\comodogroup\cdi\1\shortcuts\2\ShortcutName : COMODO Internet Security
HKEY_LOCAL_MACHINE\software\comodogroup\cdi\1\shortcuts\2\RelativeFol : \COMODO\COMODO Internet Security\

I enclose a screenshot of the files installed under folder COMODO Internet Security.
Also, during the installation I am not asked whether I want to install the firewall only or antivirus, I only want firewall.

This is becoming a very intriguing story guys, never seen anything like this in my long experience as a PC freak >:(

Looking forward to read your comments!


[attachment deleted by admin]

After this “more or less” clean install, did you get the screen where you can chose to go to Pro or say “No Thanks” ?

The processes you should have running are cmdagent.exe and cfp.exe (gui).

Please also check your windows eventlog (system) to see if something fails on boot.

And also post your system details, like version/sp/language 32/64 bit
Any other security applications installed whether real-time or on demand does not mater.

To answer your first question: No, I didn’t get the screen where you can chose to go to Pro or say “No Thanks”

To answer your second question: None of the processes are running.

To answer your third question: As in signature: WXP PRO SP3 - Antivirus → Avast Home Edition

My system is clean, no virus, spyware etc. and overall, never a problem with Comodo before this one.

I was waiting somebody to react before going back with True Image backup… but still, if you have better ideas, I will wait your reply. For sure, this is really weird to me, there is nothing of Comodo in my system but I cannot install a new CIS :o
I ran also the CFP 3 File+Registry Cleaner.bat I found in this forum, but during the process I clearly could read that there was anything to unistall because I had already removed all the Comodo registry keys, as well as, folders etc.
I guess it might well be a problem in Windows preventing the installation of Comodo, for a reason unknown to me, in fact all the rest works perfectly.

Thank you!

Have you also checked the Hardware drivers list and set the “show hidden devices” on ?
To see if there is any “Comodo miniport etc” left in there ?

Yes, no sign of any comodo driver.
I am now going back with Acronis True Image, I’ve been spending two days on this bloody problem and apparently there is no solution, hope the backup will bring things back as good!

Thank you


Okay, let us know how it went okay ?

Groetjes terug.


I have the same problem as Metallo. I have tried uninstalling with the batch file from the forum and followed the instructions in

Then I installed the latest 3.9.95478 version, but still unable to run cfp.exe or cfpconfg.exe. During the installation I didnt see the options to choose firewall or antivirus or both.

Its really frustrating that the installation cannot even be completed properly… I’ve run out of ideas to install this firewall. Can anyone advise please?

Hello Problem,

Can you tell us a bit more about your system like OS/version 32/64bit other security software, what was your previous version of COMODO ? Internet security of Firewall Pro ? 3.0.x ?

Did the installer prompt you to reboot at the end of it ?

I’m on Windows XP SP2 32bit, with AVG antivirus ver 8.5

I can’t remember the previous version of CIS that I was using, but it was somewhere in the first few months of this year… so should be at least 3.5.x. I was using CFP and am still trying to continue using it.

The installer did prompt me to reboot. This was after choosing the install destination and the installing (extracting files, installing files & creating shortcuts). I was never asked whether to install for CFP only so I’m guessing that a few steps were missed.

After reboot there are no cfp or cmdagent processes running, and I cannot open the CIS gui.

Do You Receive Any Error Message while Trying To Open The GUI ? Did You Tried To Manually Start Those Services From The Services Console ?

When I double click cfp.exe, nothing happens - no errors, no window appearing. I also cannot run cfpconfg.exe. I don’t see any comodo services in the services console (services.msc).


It Seems To Be Something Went Wrong With The Installation. Try Unistalling CIS And Check After Installing It Back From Safe Mode.

Hello Problem,

I think your install went bad for some reason.
Is it possible to start the uninstaller or doesn’t that work either ?

like napsterz is suggesting :wink: