Comodo Disk Encryption BETA Bug Reports

In preparation for Comodo Disk Encryption, Coming Soon! :slight_smile:

Thread locked for now.

Thread opened for bug reporting.

I have a problem. I installed the beta, tried it and removed it. However, everytime I start my computer now, it beeps twice and loads normally. The beeping is irritating and I can’t get rid of it. I did a clean install and bios re-install, which didn’t help. I then installed the program but everytime I try to run it I get the BlueScreen.

Vista Home Premium SP1
Please Help,

Could you please be more specific about this scenario!
The computer beeps twice because it attempts to access USB.
You said “I did a clean install and bios re-install, which didn’t help”. Re-installing BIOS does not solve the problem and should not be performed by end-user. You did a clean install to windows? Be more accurate!

The ‘beeping’ problem will be fixed in a future release. It is generated by CDE at boot time for debug reasons.

We are very interested about this and if you can please give us as many details as possible. If it’s a bug we are here to fix it.

My drive has 4 partitions. I encrypted one partition, then I decrypted it. Everytime I start the computer it beeps twice after the bios loads and then continues to load normally. It was irritating so I ghosted my drive back to a few months ago (Norton Ghost 12–Image of Vista HP SP1).
This didn’t work so I decided to try flashing my BIOS over which also didn’t work. Then I attempted to install the beta. The install was successfull. However, when I tried to run the program I got the Blue Screen (5 attempts).

Below is the error sent to Microsft after the Blue Screen.

Problem signature
Problem Event Name: BlueScreen
OS Version: 6.0.6001.
Locale ID: 11273

Files that help describe the problem (some files may no longer be available)

View a temporary copy of these files
Warning: If a virus or other security threat caused the problem, opening a copy of the files could harm your computer.

Extra information about the problem
BCCode: 1000008e
BCP1: C0000005
BCP2: 82411E25
BCP3: 8FC748F8
BCP4: 00000000
OS Version: 6_0_6001
Service Pack: 1_0
Product: 768_1
Server information: 6b048016-c0a3-4eb9-83eb-88f0ad69ea21

I am unable to upload the attach 3 files.

I have a Dell Latitude 810, 2GB RAM, 80GB HD.


Hi Team,

the beep-thing is indeed annoying.

I encrypted an external USB-HD (drive F) and used the USB stick as drive G.

After encryption, I have no longer access to drive F.

Upon connecting the USB-HD a Windows message pops up that the drive needs to be formatted (this sounds normal due to the encryption of the whole drive).
Same message pops up when connecting the USB-stick with encryption information (Drive G).

I’m attaching a printscreen from “key-tools”

Already tried a few times to re-install CDE but with the same results… no access to the encrypted F-drive anymore…

Harry (:NRD)

[attachment deleted by admin]


Encryption algorithm isn’t displayed in key tools window.
This can happen when :

  1. usb-stick is removed during encryption process.
  2. accidentally restarted the system during encryption process.

You must keep the USB key plugged in the following situations:

  1. At boot time.
  2. while encrypting/decrypting/editing partitions.

We will remove that beeps at release version.

Thanks Ionut,

so in order to use the drive I need to format the drive and start a new encryption?




  1. Format that external Disk.
  2. Open Comodo Disk Encryption.
  3. Clear the usb key and create a new one.
  4. Start encryption process, but keep the USB key plugged in until the encryption process is finished.
  5. If you want to access that partition also after restart, you must keep the USB key plugged in at boot time.

Any feedback with the BlueScreen that I got?


You said "I ghosted my drive back to a few months ago (Norton Ghost 12--Image of Vista HP SP1)".

We do not have this software so we haven't reproduced the bug. My guess is that this software doesn't restore the whole disk (probably just partitions); if so it is not a surprise to get a BSOD. 

Anyway we plan to make some changes in beta 2 and no beeping will be heard.

I have been through the entire process like you described, step by step, exactly like you said.
I have two partitions, and I have decided to encrypt the second partition (logical drive, 5 GB)
I can not access that partition anymore, and Windows said “the drive is not formatted…”.

CDE can not see this partition anymore, it shows only the primary partition (C: drive) as “Not Encrypted”.
I still want to see the data on my D: drive, but it seems it is not possible, even if I boot from the USB key.

In the “Key Tools” it seems to be OK… please look for attachment…
Anyone could help? Thanks!

[attachment deleted by admin]

Please check your BIOS settings to make sure that your computer is able to boot from a USB device. Have you heard that double beep at startup?

YES, I have already check this, and I have booted from another USB Stick, with Hiren’s Boot CD on it, and it’s working like a charm…
I booted again from the CDE’s USB key, it still can’t show the encrypted partition.
Maybe there are some incompatibility with my PC: IBM ThinkPad T42 ???

I have flashed my BIOS with update version 3.23 and now it’s working perfect!
Tkanks, COMODO Team!
P.S.: Note that there is incompability between CDE and IBM T42 bios version 3.21! If you had this BIOS version (3.21), you need to update ASAP!

New Beta is out! and new bug report thread is now opened: