Comodo did not disable Windows XP firewall

I ran a thesaurus utility (Mobysaurus) and got a message from Windows XP Firewall asking if I want to allow the program to run. I thought that Comodo automatically disables Windows Firewall.

Should I disable it myself? Or should I just leave both running?


Disable windows firewall, Check that windows sees Comodo firewall in security center.
If a reboot doesn’t make it right (ie sees comodo). In the unlikely event it doesn’t.
You may need to run the installer again.


[at] mortyschiller
And welcome to us and the forum.

There is a case when CIS couldn’t disable Windows Firewall:
If the machine is connected or used in a corporate network and their Group Policys affect this machine in a security aspect (user couldn’t change security settings), then CIS can’t disable WF at all.
If that’s the case, you could see that in your control panel where WF’s settings are outgrayed. There is a way around this IF the machine runs outside a corporate network in which case a change in the local Group Policys can be made. But that change reverts when the machine connects to the corporate network again.

But if that’s not the case, I’ve no idea. Execept what Bad says.

This response implies that Windows (I have XP SP3) should recognize the existence of the Comodo firewall. It doesn’t, at least not on my relatively new custom computer. ().

The mobo in this computer (Intel DQ35JO mobo with E8400 Core 2 duo CPU) is one of the first to have a Trusted Platform Module, which the DOD announced it will require on ALL laptops it uses beginning in 2011. I used to use Avanquest’s SystemSuite as my do-all utility (firewall, AV, AS, PC diagnostics, cleanup, etc.). I quickly found that it had some incompatibilities with the TPM, even when the latter is disabled in the BIOS. Specifically, with SS loaded, the computer ignores the Power Settings; will not go into standby or hibernate at the times specified, and if you put it into either of those manually, when you bring the system out of either, the OS crashes causing an automatic reboot.

Is it possible that the TPM is also causing Windows to NOT recognize that Comodo is my firewall?

I have 3 Windows boxes at home plus a friend’s computer that I remote and maintain all running XP Pro w/SP3 and all running CIS 3.8 (477). I found out by accident the other day that Windows Firewall was not disabled on any of them. It did not cause any problems but I did manually disable WF but failed to check if Comodo was recognized until after the fact.


I have a PC(Xp Home) and a Laptop(Xp Pro) and both of them CIS didn’t disable Win. firewall. I desabled manually.

I’m using the Firewall and D+ components of CIS 3.8, and I also had to manually disable the windows firewall after installing it. Using Vista 32.

It’s interesting (and a little worrying) that it seems hit and miss.

When I installed CIS on my machine the windows firewall wasn’t disabled by CIS, but just yesterday I installed it on my sisters machine and it did disable the firewall… (Both machines running WinXP Pro)

It didn’t disable it on my main Windows installation but it did on my VM. Both were running Vista. ???

My windows firewall was also left running. I don’t consider this a bug, rather an extra step that needs to be done with a new installation.

Same problem under vista x64
Installed comodo
would have expected it to shut down windows firewall automatically

got a surprise when I ran a prog that was not on cleared list & windows firewall gave a message saying allow / block instead of Comodo.

I sometimes forget to disable Windows Firewall when doing a clean install of CIS. It’s just a bit annoying…on the other hand its a minor shortcoming in my eyes… (:NRD)