comodo defense+ and winrar 64bit

hey all,
i just bought winrar 3.92 64bit and installed it on my win7 64bit ult laptop. since then i haven’t been able to open up my control panel. whenever i attempt to launch my control panel, it’ll open and enumerate all the icons but then pops up with a box saying"windows explorer stopped working." then closes out the window.

each time this happens, my application event log gets this error:

Faulting application name: explorer.exe, version: 6.1.7600.16450, time
stamp: 0x4aebab8d

Faulting module name: SHELL32.dll, version: 6.1.7600.16385, time stamp:

Exception code: 0xc0000005

Fault offset: 0x00000000000950a5

Faulting process id: 0xdac

Faulting application start time: 0x01cabfc14f98e113

Faulting application path: C:\Windows\explorer.exe

Faulting module path: C:\Windows\system32\SHELL32.dll

Report Id: 8dd7d452-2bb4-11df-b873-00188bc2f2aa

i emailed winrar and they said they’ve tried to reproduce the problem but couldn’t. they think it has something to do with comodo catching the winrar shell dll or something. i ran autoruns.exe(from sysinternals) and i do see the rarext.dll and rarext32.dll entries. i have a feeling it has something to do with these but im not sure. i was running winrar 32bit fine before. seems like this 64bit version doesn’t work. the application itself still runs and extracts files and what not, but control panel doesn’t like to open all the time. it seems random.

im running bitdefender 2010 AV. and just comodo firewall 3.14.130099.587 with defense+. im a semi noob to defense+ and its configuration. but i did add “C:\Program Files\WinRAR” to “My own safe files”

Well, the easiest way to approach this problem is to disable CIS (unplug network), so you can see if this is a CIS problem or not.