Comodo creates multiple entries for the same application

Recently Comodo started asking me the same question about granting Internet access to the KMPlayer and no matter what I choose and whether I check to remember my choce or not it asks me this again. I checked applications rules and found that KMPlayer entry has a lot of rules that are exactly identical. But what’s even more weird - I found another entry for that program with a DOS-style wtitten path. So I have these entries:

  1. С:\program Files (x86)\The KMPlayer\KMPlayer.exe
  2. C:\PROGRA~2\The KMPlayer\KMPlayer.exe

When I delete these rules and create a rule for the program choosing it’s location on the disk Comodo creates first entry. And if I add a rule choosing from active processes Comodo creates second entry. Though it is exactly the same program in each case. And when I run KMPlayer Comodo disregards both entries and asks me anyway, then creates new rule in C:\PROGRA~2\The KMPlayer\KMPlayer.exe entry. And it does that every time so that “C:\PROGRA~2\The KMPlayer\KMPlayer.exe” entry has an increasing number of identical rules. By the way Comodo asks this same question multiple times in a row,though I ask to remember my choice every time.

I found this similar thread https://forums.comodo.com/firewall-help-cis/firewall-asks-the-same-thing-over-and-over-again-creates-multiple-entries-t63069.0.html but in my case the application (KMPlayer) is definitely not on some kind of external drive.

Is there a way to overcome this problem without changing Comodo’s firewall policy?

For stubborn apps I have found that sometimes changing the policy to Installer or Updater works to stop these.

This happens because CIS recognizes files by their file hash. If there has been a change to the application, (and there are numerous legitimate reasons an application may do this) the next time it starts, CIS sees it as a new application and gives it a new rule.

As laserfan suggested, until the developers add a more elegant way to do this, you can give these applications the Installer or Updater policy.

Many thanks–I did not know this!
:-TU

laserfan, HeffeD thanks for the answers!

I understand that but in my case pop-ups were displayed several times while the program was running. For example I launch KMPlayer to watch a movie and start getting these pop-ups every 5 seconds and it is unstoppable even when I ask to remember my choice. Is it possible that the program is constantly updating itself especially without an Internet access? And what’s more important I have windows 7 with UAC on and the program just can’t change itself without windows asking a user to allow this. So I don’t think KMPlayer’s hash was changing.

By the way, I used Outpost firewall for a while and when a program’s hash was changed Outpost asked to update it’s rules and not to create new ones. It seems like a more user-friendly behavior so I hope Comodo firewall will have that functionality someday soon :slight_smile:

This behaviour has been seen several times before and it has something to do with the way the users system handles DOS 8.3 filenames. I did try to recreate the problem, unfortunately without success.

FW rule is not acted on, probably due to 8.3 DOS name issue [Issue: #260]

Have you disabled 8.3 filename support?

By the way, I used Outpost firewall for a while and when a program's hash was changed Outpost asked to update it's rules and not to create new ones. It seems like a more user-friendly behavior so I hope Comodo firewall will have that functionality someday soon Smiley

CIS works in a very similar way. Depending on your settings, you will receive one or more alerts for the ‘newly identified’ application.

That looks exactly like the problem I encountered. The problem was not solved in that thread though. By the way I found this in CIS’s change log here http://wiki.comodo.com/CIS/Help_Guide/General/Whats_New:

Version 3.0.14.276 ... Eliminated 8.3 path conversion and its associated duplicate entries/not remembering my answer problems (e.g. for BOClean or AVG)

I guess it was not completely eliminated :slight_smile:

I don’t know what exactly happened but I don’t get those pop-ups anymore. Since I started the thread there was a CIS update maybe it helped. But I had KMPlayer for a long time and pop-ups began to appear only recently so I think the reason for that was the same - a previous CIS update :slight_smile: so it works for now, thanks to everybody for your help!