Comodo conflict with Malwarebytes-Anti-Exploit [M2190]

When opening browsers (firefox at my case), Malwarebytes-Anti-Exploit blocks the browser. This issue is reported in their site, which declares the fix need to come from Comodo:

New Comodo Bug. We found a second new bug in Comodo which may cause conflict with MBAE and result in browsers not being able to open correctly. It seems when MBAE injects after Comodo there is no problem, but if Comodo injects after MBAE then Comodo doesn't handle the chained hooks correctly. A fresh re-install of MBAE might temporarily solve the problem (as it sometimes makes MBAE handle the API hooks after Comodo) but the definite bug fix must come from Comodo.

When opening browsers (firefox at my case), Malwarebytes-Anti-Exploit blocks the browser, whuich indicates a possible conflict with CIS.
Can you reproduce the problem & if so how reliably?:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:turn on MAE
2:Open firefox browser
3:Firefox is blocked by MAE
One or two sentences explaining what actually happened:
Firefox did not open and MAE showed a notification about blocking an exploit, via its “application hardening Anti heapsprey Enforcment layer”.
One or two sentences explaining what you expected to happen:
For Firefox to open as usual
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Disabling all of Comodo’s components does not fix the problem. I tried to use other Firefox installation (the Tor browser) which didn’t run when MAE was turned on but did not make MAE show a notification. I added browsers to the exclusions of “detect shellcode injections” in HIPS settings and it didn’t help. I have secure shopping and it was disabled.
Any software except CIS/OS involved? If so - name, & exact version:
Malwarebytes-Anti-Exploit v1.09.1.1362 (standalone).
Firefox 52.0.2 (32-bit).
Any other information, eg your guess at the cause, how you tried to fix it etc:
Could be an Issue with MAE alone, or a conflict with Comodo. There are compatibility problems according to Malwarebytes forum: Known Issues & Conflicts - Updated April 16, 2020 - Anti-Exploit Beta - Malwarebytes Forums

Exact CIS version & configuration:, default configuration
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
All enabled, the issue exist when they are disabled too.
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
64bit administator Windows 7
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes b=Zemana Anti Malware (which was turned off) c=MBAE (standalone)

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)

Can you edit your post to be in the required bug report format? And can you include info about the browser used such as version and type (32-bit or 64-bit build of browser) Thanks.

I’ve checked the issue agian with all of the components of CIS disabled to be sure, But MAE still blocked the browser, so I guess my issue specifically isn’t a CIS and MAE conflict but only an issue with MAE, and therefor not a bug, my bad.

anyway the issues in their bug tracker still exist, if the developers of CIS don’t know about it already.

Even when you disable all components of CIS it can still cause conflicts because the protection dll guard32.dll/guard64.dll is still injected into every process. This dll hooks various Windows API functions which I’m sure overlaps with hooks from MBAE. To prevent possible conflict you should add the browser to the exclusions of detect shellcode injections in HIPS settings, which still goes into effect when HIPS is disabled, though make sure detect shellcode injections is left enabled/checked. Also with the release of secure shopping, a conflict can arise with the secure shopping modules cssguard32.dll/cssguard64.dll.

Disabling all components can still cause conflicts btw.

I think the problem is with either Comodo Internet Security Essentials or Secure Shopping.
Before I used CFW with MBAE and I didn’t have any issue

Actually, it’s not a new issue. I was not able to replicate the issue back then. Either that or I was making a cheat sheet full of lines girls love to hear their men say. I’m not so sure. ^

Its still unclear what version of firefox and type (32-bit or 64-bit build) and what version of MAE are you using? Is it the standalone or one bundled with MBAM? And have you tried adding firefox to the exclusions of detect shellcode injections in HIPS settings? Also do you have Secure Shopping and/or Internet Security Essentials installed? If yes have you tried to uninstall or disabled those separate programs and check to see if issue persists?

I had no problems opening firefox v52.0 64-bit with MAE standalone version on a Windows 7 system which also has Secure Shopping installed and enabled.

Firefox 52.0.2 (32-bit), MBAE (standalone). I added browsers to the exclusions of “detect shellcode injections” in HIPS settings and it didn’t help. I have secure shopping and it was disabled but I don’t have Internet Security Essentials. I also just noticed MBAE shows me a pop up when I close a firefox windows too.

Please check again with Comodo Internet Security v10.0.1.6209 thanks.

Still experiencing it.

Please check if issue still occurs with Comodo Internet Security v10.0.1.6294 thanks.

This is most likely fixed, malwarebytes added dynamic hooking to manage conflicts, and having multiple 3rd-pary security software installed increases compatibility issues and conflicts. If you still experience the bug please create a video and also try with only MBAE and CIS only installed. Moving to resolved.