Comodo CIS cmdagent.exe high RAM/working set memory spike usage

As recommended by a moderator, I am filing a bug report on unusual activity that seems to be slightly reproducible, and is related to a certain program.

A. THE BUG/ISSUE: cmdagent.exe suddenly spiking RAM use or Working Set memory, before dropping all used and resuming function. Occurs semi-randomly, occurs more often the more activity I generate on my PC

  1. What you did: Reinstalled a subject program called “Blacklight Retribution”, a F2P game for a writeup. Issue has happened before with the same program
  2. What actually happened or you actually saw:near-vertical RAM usage in taskmanager, confirmed to be cmdagent.exe via Performance Monitor, and is working set memory. Associated CPU usage increase to go along only part of the time
  3. What you expected to happen or see: cmdagent not bloating to high RAM use (as high as 3-4 GB of working set memory)
  4. How you tried to fix it & what happened: Yes, only known fix that worked for me was a un/reinstall of CIS
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: Subject program has no notice of any incompatibility with Comodo
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Simply just installing the game itself causes the RAM spikes to appear. Uninstalling the game does not make the spikes go away.
  8. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
  2. Screenshots illustrating the bug: <–my own ← Picture found of an exact match of the issue from a tom’s hardware forum post
  3. Screenshots of related CIS event logs:No event logs match up with RAM spiking
  4. A CIS config report or file:
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version:


  1. CIS version, AV database version & configuration:CIS Premium 5.10.228257.2253 Virus Sig DB 12748 config file is above
  2. a) Have you updated (without uninstall) from a previous version of CIS:Yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Yes, already done the first time, issue reappeared via a reinstall of subject program
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: AV: Stateful, Firewall: Safe, Defense: Safe, Sandbox: Enabled
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 Pro 64bit SP 1, UAC on, Admin account
  7. Other security and utility software currently installed:Malwarebytes Free (no active protection), Spywareblaster Free (no auto-update)
  8. Other security software previously installed at any time since Windows was last installed: Only CIS had first dibs on AV, Firewall, and HIPS standing for my system, Malwarebytes Free and Spywareblaster used as support tools
  9. Virtual machine used (Please do NOT use Virtual box):No

To whom it may concern:

If you require additional info from me to finalize this bug report, please do so within the next 24 hours. I am about to remove CIS due to this issue becoming a detriment to my workflow.

Excellent report thanks. Just a confirmation of the game version which caused the problem missing.

Best wishes


Game version may mean little, as it has happened before and after its Steam release as a F2P game, which means it covers multiple game versions over a span of 3-4 months, not including the time when I had it uninstalled and reinstalled just this week. Anyway the current game version I have installed is:

Launcher version: CL_2012_04_28_18_04
Game version: V0.971

Both CIS and the game will be uninstalled within the hour of this post (offline, of course, as I intend to replace it immediately so as not to expose a naked system). I hope you guys can get to the bottom of the issue, as my own research points to it not being totally related to one game.

However, Blacklight Retribution runs on the Unreal Engine, a common videogame engine…


If you have not uninstalled yet, try adding its main executable and the copy protection service Steam executables etc to BO exemptions (D+ settings ~ Executaion Control Tab ~ Exclusions) and rebooting.

There is a good chance that this will solve it if you have not tried it already.

Good luck, and sorry if I am not in time. Only just though you might not have tried this.


Didnt make it. Also adding Steam and Blacklight Retribution to exception list did not help. Tried that already.

Also, after unninstalling CIS, my CPU is finally reporting 0% utilization for the first time since I owned this PC. This means that CIS was either bloated to high heck from a year of use, or my setup simply was not favorable to it and it kept running background processes slowing my PC down unnecessarily.

Sorry it did not work. Moving now.