Comodo causing lag, lockups, explorer.exe crashes. Please Help

Need help with a series of problem’s i’ve been having. I’ve been trying to solve this on my own for weeks so i think it’s time i tried to see if anyone on this forum had ideas on how to solve this. If i need to attach any log files or stuff please mention them and i’ll do so.

To explain what’s been happening: i go to change the settings, it works, i close the window. I remember i also wanted to change something else, try to repopen it, doesnt, but cpu usage starts spiking. In task manager you can see Any new processes from comodo are locked at 13 cpu usage constantly, one more for each new thing clicked, whether that be a log or options menu im trying to open.

Now, no new applications will open including notepad++, chrome, Run, foobar2000, nothing works, only comodo will open new processes and they are all locked at that 13 cpu figure. I can end those processes, and i did. Also when in this state it ends up not properly disabling:

After thiis explorer.exe often crashes or goes not responding, so does the windows window specialized to close programs when explorer isnt responding. all programs eventually go not responding, faster if they need to open a new window or take a similar action. Mouse never stops responding.

other symptoms are hitching as if comodo is interupting a program trying to read from the disk, aka why i was trying to change the settings in the first place. Also, often comodo security agent (the GUI) doesnt launch the first try on start. It gives me a “could not be started” error then i have to start it manually and it works fine. In this case, the underlying comodo processes seem to still be functioning normally even if the GUI isn’t launched. Also always have two instances of svchost (pid 1468 andf 2008) always running in the sandbox for some reason.

I’ve tried to remove then reinstall comodo, while removed none of these problems manifest but reinstalling doesnt fix it. Sweeped with mbam already, full scans, i really doubt this is an infection of the malicious kind at least. Anyone have ideas? I would REALLY appreciate any assistance

edit: it managed to recover from this situaton once just now by itself. Not sure what was different this time.

well, i guess i need to stop using comodo. I’ve uninstalled it and a bunch of other seemingly unrelated issues were cleared up.

Why was comodo blocking several applications from running properly without logging anything? ugh.

Did you try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.