Comodo causes TV image stuttering in Vista Media Center, any ideas??

I’m having a problem with watching TV in Vista Media Center, the image stutters every now and then, especially in recorded shows. I’ve tracked the problem down to Comodo, since with it being disabled the playback is flawless. I do have both the antivirus and firewall options of Comodo installed, so this might be a antivir issue as well.
Has anyone experienced similar problems? Any ideas what could help?

Thank you very much for your input!

I think this has to do with blocking fragmented packets, can you check the firewall settings, Attack Detection Settings, Misc, untick “Block fragmented ip datagrams”.

See if that helps.

I have it ticked, and WMC runs fine. The only issue I have is not with Comodo CIS, but rather any data transfers. WMC displays lines of static on screen during data transfers. Otherwise, clear image live and recorded.

Have you checked you Defence+ logs and Network logs to see if anything is blocked.

Thanks guys for your quick replies!

I tried this but it seems that the problem is elsewhere, I made some more investigations on the issue and it seems that this problem is not solely related to Comodo.
The other night I watched a movie and it was skipping like crazy, and disabling Comodo fixed the problem then. But now yesterday most channels worked just fine without any skipping. Then I started recording one channel and watch another simultaneously, and it started to skip a little about once or twice a minute or so. It’s just a small glitch and does not affect the audio, only the image, tiny but noticeable. But now even disabling comodo did not solve the problem, so there has to be something else causing problems as well… There’s no spikes in the CPU usage, load stays below 20%, memory usage 40% or so. Dual core processor and dual receiver terrestial TV card (Terratec 2400i).
This is really weird, since the other day shutting down Comodo solved the stuttering, but now it doesn’t. I’ll have to do some more research and experiments, hopefully something will help. It might also be a data transfer related problem, maybe also related to the WLAN card/drivers, who knows.
Anyway, thanks again guys for your help.

You could try to export your configuration and uninstall CFP, see if it’s totally gone then ?
Even if disabled there are always drivers loaded that “could” be causing trouble.

CIS would have nothing to do with this issue as WMC accesses the Tuner card for display. The Internet is used solely for updating program guides.
The bands of irritation being seen I believe is the same as what I see (try turning off any programs that are accessing the Internet for file transfers, etc. You should then see a clean picture,

first,you could see the firewall log and find the problem.