Comodo "blocks" Wifi

why does Comodo block my wireless connections?

I’ve created a trusted zone for my wireless network.
I dont see any blocked connections in the log, so im not sure
if it’s actually blocking the wireless connection, but somewhere along the line
it’s not getting through.

I’ve been using Zone alarm along time but got fed up with it.
Commodo seems like a pretty nice prog and works well except for this little
problem, so I would really appreciate the help.

edit: [RESOLVED] removed by Mod.

Hi Skiba,
I too just switched from ZoneAlarm (free) to Comodo Firewall because of an online review I read that rated Comodo very high and Zonealarm (free) as very poor.

However, Comodo destroyed my AutoCAD installation, I also couldn’t plot to my large format plotter out of AutoCAD and my small printer stopped working.

So after uninstalling and reinstalling ACAD I went back to Zonealarm (free). At least now everything works once again. So, for me, poor security with everything working is better than top shelf security with nothing working.

I hope your problem gets fixed.


Welcome to the forums, skiba ~

You may have done so already, but there is a tutorial on setting up your wifi…;msg45481#msg45481

Item three might be of interest there; the author (pandlouk) notes that you only want the router IP as the trusted zone.

Anything CFP is blocking will be listed in the Logs. We can ■■■■■ those open if need be to get it resolved for you.


PS: maalox, I’m sorry the firewall gave you such a sour stomach. If your printers were networked, you would need to create network rules to accomodate access. If they were not networked, there is no reason for CFP to interfere. Again, Logs would show the activity. Also, you may have experienced issues (as a large # of former ZA users have) that ZA does not actually uninstall when it is supposed to. It leaves behind what amounts to a residual firewall, and causes all manner of strange conflicts. There are custom uninstall tools available on the web for this very reason. If you are willing to give it a go, I am confident that all your problems can be resolved (well, for the firewall, anyway - we can’t help with personal problems… :wink: ).

Yes I’ve read the tutorial but it’s mainly about tightening the Wifi security, and thats not the problem I have. I use my mobile on the Wifi. CFP actually causes my phone to freeze up as it can’t get online…
Works fine when I turn CFP off.
I dont get any blocks in the log, so I wonder if it’s some other special feature/rule in the advanced security configurations. In the installation I did choose user defined rules instead of CFP choosing the rules for me, so maybe that has something to do with it :-
I also have checked in the network monitoring that all the wireles adaptor rules are set to “allow”, but no luck.


In my experience, users that choose the Advanced install mode instead of the Automatic typically end up with some issues, since it requires manual configuration of rules - and most if not all new users are clueless when it comes to Comodo configuration (not an insult; it’s just so different from other firewalls, with its layered security and all). That may or may not be part of your issue.

Another possibility is that other security software was left active during install; this frequently causes problems. Or the remains of a previous firewall (especially Zone Alarm or Norton). If there are no long entries, I’m suspicious of one of these… regardless of the reason, if CFP is blocking something, it will be in the logs.

But here’s your next diagnostic test. This is for brief testing purposes only. Do not leave the firewall this way for more than a few minutes.

Change the Security Level from Custom to Allow All. Then try to connect your phone; see what happens. After the test, return to Custom.

If it connects fine, we have a rules issue within CFP. We’ll just have to track it down. If it still doesn’t connect, I’d recommend an uninstall (with all security apps OFF), clean registry, reinstall (with all security apps OFF). We’ll go thru all that in more detail when the time comes; this is just to give you the heads-up.


Ok I tried the test and the wireless works when I set CFP to “allow all”.
After I returned to “custom” the wireless worked for awhile, till I booted up.

I allso re-installed CFP to a clean registry and selected the recomended automatic rules, but didnt have any effect.

Okay, so if Allow All still works after the reinstall, but Custom doesn’t, we know we have an issue with Comodo’s rules. The most common “trouble spot” (especially for networking-related issues) is the Network Monitor. The logs should hold our keys…

Go to Activity/Logs. Right-click any entry and select “Clear all logs.” Then reboot and try to connect to the wifi.

When it’s blocked/doesn’t work, go back to Activity/Logs. Right-click any entry and select “Export to HTML.” Save and then reopen the file (it will open in your browser).

Highlight the entries, and Copy them. Then Paste into your next post here. If your external IP address shows (it will match the IP shown in the lower right corner of your posts in the forum), you may mask/edit it with ‘x’ for privacy.

Then we’ll see what’s what there.


OK. just so you know I again re-installed Comodo, and set the power user mode. Too many unwanted blocks…

Heres the log

[i]~Edited by mod: Please do not post the entire log. Rather, upload it as a file~

[attachment deleted by admin]

Hi skiba

Looking at your Log entries… there is NetBIOS, IP multicasting broadcasts & a few different LAN IPs. How does your phone connect to the LAN? Does it have its own LAN IP? Also… have you set-up a Trusted Zone that contains all your LAN IPs (including routers, etc…) of trusted elements?

I think I found the problem or atlest solved it. For some reason I need to have the ASUS WiFi prog running always when I use the wireles. The wireles netwoks has worked without it with Zone Alarm, but I guess CFP is more picky. Got it solved atleast for now. thank for the help guys.

That’s good. The application will create rules that bypass the Network Monitor, that’s probably why it works.

I’ll mark this topic [RESOLVED] & close it. If you need it opened again, just send a PM to a Mod.

didn’t work after all. I noticed that when I set " allow all" and then back to “custom” the wireless works for awhile as it should. Heres a few lines from the log when I was able use the wireless on custom setting. Hope this helps…

[attachment deleted by admin]

I’m not sure if this is relevant in the Firewall FAQ’s:

[b]Wifi-LAN Protection[/b],361.0.html

Can you post a maximized screen shot of your Network Monitor rules, thanks. It could be that the ASUS WiFi program closes its listening ports after a certain time-period, then causing the incoming packets to be hitting a port that nothing is listening on & thus being treated as unsolicited by CFP.

I cannot see anything in particular in the Log you posted. They were all incoming HTTP’s from various sources (web sites) & a couple of DNS returns from (your router?). There were no Outgoing events recorded.

Here you go.

[attachment deleted by admin]

Rule 9 looks a little odd… in a very open way. Allow TCP/UDP IN/OUT Any Any… is that right?

What is the Marvell Yukon zone?

I think (not running 2.4 at the moment) that rule 4 (TCP/UP out) should be at the rule 0 position. This is used when the outgoing item has already been filtered through the Application and Component Monitors & just needs to be sent on its way… I don’t think it needs to filtered through the Trusted Zones first… - I’m sure someone will jump in if I’ve got this wrong.