Comodo blocks my browser

I just clicked on block instead of allow for one of the occasional commodo pop-ups regarding firefox, and now I can’t use the browser as long as comodo is active. How can I undo this?

I’ve tried entering firefox.exe as a trusted application, but that doesn’t help. There’s no blocked entry for firefox, as far as I can see.

Any help will be greatly appreciated.

is it possible that your problem caused by CAVS HIPS intead of CFP?are you using CAVS too?
try open CAVS-setting-HIPS application control-manage allow/block list.

If possible please can you post a screenshot of your application monitor rules or list any blocked applications from there, preferably with parent applications.