Comodo blocks Microsoft Update [Solved]


OS is XP Home SP2, been using Comodo since 20/11/2006. Everything was working ok till today.

Went for the Microsoft Update site and it gives error 0x80072EFD

Right-click on the Comodo icon in tray, adjust Security Level to “Allow all”, returned to Microsoft Update site and it detecs the 10 new updates MS released yesterday.


Do you always download the MS updates online, or do you use Updater? (that’s just a question; may not be pertinent to this issue, but if you use Updater you may need to make an application rule…)

If setting CPF to “Allow all” fixed the issue, then CPF is blocking something needed for the MSUpdate site.

Here’s my quick solution, which in my experience resolves issues the majority of the time:

Go to Security/Tasks/Scan for Known Applications (lower right). Follow the prompts. Reboot when finished. (it may tell you to stop/restart CPF; just reboot entirely…)

See if that resolves it (don’t leave security at “Allow all;” move back to “Custom.”). Also, make sure your Component Monitor is set to Learn rather than On (to cause a prompt).


PS: Welcome to the forums! (:WAV)

Make this rule and see if it helps:

[b]ALLOW-check the checkbox

Source IP: Pick Host Name and use “
Dest. IP: I use my machine name here but you can also use your IP address or ANY
Source Port: any
Dest. Port: any[/b]

Be sure to put it above all your block rules.

Hope this helps.



Always online.

Had already scanned for known applications when installed CPF. Will try again.
Am on the middle of something so can only reboot in a while.

Obvious. (:TNG)

Thanks. The forums were what convinced me to install CPF.


So easy! (:SHY)

When I initially stablished ADSL connection, I was used to block svchost because it appeared with a SpeedFan warning. This time allowed it and Microsoft is now updating my OS.

Thanks for the help!
Continue the good work. (:WAV)

Nice that it works for you now. ;D
svchost is often the problem when there is a connection problem… :wink:
Good luck with CFP.

(note to self: svchost.exe cannot be blocked or bad things happen…) :THNK

Heh! Glad it’s working for you now. :BNC

If all is well for this issue, would you please go to your first post in this thread, click the edit button (lower right, just above your IP address), and add “[Resolved]” to the Subject line, either before or after your original text/title. This way other users searching through will know there is a potential answer…

Keep poking around, and ask questions as you need. If you do a search on Network Control Rules, you’ll find an excellent guide by m0ng0d; I highly recommend reading that, since the NCR really sets the stage for everything in CPF. I’d post the link, but I’m at home on my wife’s computer, and don’t have it handy.




This one?,1125.0.html

Yes I think he meant that one. :slight_smile:

I will lock this thread for others benefit.

Yes, that is the one I meant. Happy reading!