Comodo blocks localhost?


Mysterious and very annoying problem came out when I installed Comodo Internet Security. Capture One raw image prosessing software stops working, and I guess it’s because Capture One tries to connect to localhost, and Comodo blocks it. That’s what I read from Capture One’s forums.

Anyway, I get following error message: No connection could be made because the target machine actively refused it. Then Capture One freezes. I set Capture One as Trusted Application but that does not help. Only way that I found is to set Comodo Firewall Security Level to Disabled. Then it works, so the problem is Comodo.

Any ideas?

Welcome to the forums, darxide!

CIS does protect the loopback IP address space, just like any other network connection.

To make sure that you get notifications on loopback addresses, check the setting of the checkbox in Firewall, Advanced, Firewall Behaviour Settings, and then the Alert Settings tab. There is a checkbox in the lower right corner that needs to be marked (Enable Alerts for Loopback Requests).

So you establish firewall rules on the loopback address space, My Network Zone (click Firewall, Common Tasks) should have a Loopback Zone defined. You can use this zone to create a rule for your application if need be. You likely shouldn’t need such a rule, but that depends on what the CIS notification message says. If you could post a screenshot of the notification, it’d help.

Thanks for your answer!

Alerts for loopback requests was already enabled, and so was Loopback zone (IP But still I don’t get any notification at all for Capture One. Firewall security level is set to Custom policy mode, so it should alert any connection attempts.

I removed Capture One from Firewall Application Rules, but even that doesn’t trigger any alerts.