Comodo blocking nearly all programs


Excuse me for my english, its not my first language :).

I just tried to installl comodo firewall but it’s doing something really weird, it block nearly every other program. I can still run the explorer and the computer still connects to the internet but thats a bout it. When I try to start any other program it just does nothing. Comodo allso does’nt register in the defender or firewall report. When i close comodo nothing changes though, so I have no clue how to fix it. After uninstalling it my computer works fine again. I tried reinstalling, but had the same problem.
I tried looking on the forum and on google for the awser but did’nt find anything, so I hope someone here can help me.

My specs:
-Comodo version: CIS_Setup_3.8.64263.468_XP_Vista_x64
-Windows version: Vista home premium 64 bit
-Currently using avira and windows firewall (want to replace the firewall with comodo)

I hope someone can help me, because i really want to get rid of the windows firewall and get a proper one.

I have the exact same problem with Vista home premium x64 and Comodo Internet Security.

After update to v. 3.8 most (possibly all of them, didn’t check them all) x86 and one of the x64 programs stopped working. Vista UAC asks for permission for them but after that nothing happens.

I have tried to play with Comodo settings, but nothing helps but a complete uninstall.
Guess I must use Windows Firewall and Avast until this issue is resolved.

Beside this problem, Good job, Comodo!

Same here, other users are experiencing the same problem ( )