COMODO blocking me from sharing

COMODO is blocking me from sharing with other computers locally, on my local network.
I remember seeing an option or something like that when I installed COMODO.
I was wondering where is the option to turn it off, or do I have to reinstall comodo?

Open CIS and do the following:

Open Firewall
Open My Network Zones

You should see one or more Zones. The first is probably /

If your network has been automatically discovered by CIS you will see an entry for it, probably something beginning with


Assuming there is an entry in My Network Zones, for your IP address space, you will need to make sure you have not blocked it your firewall rules.

If there is no entry in My Network Zones, you will need to create one.

Here is a screenshot of my network zones:

How come comodo blocks sharing?

Thanks for that. As you can see it shows two networks, in addition to the loopback zone (127). The first is probably your home network, the second is a special address range called APIPA, which is use when a DHCP server is unavailable.

How come comodo blocks sharing?

Actually, it doesn’t.

We would need to know the addresses assigned to your Home LAN, I assume they are all within the ‘Home’ network range you have defined?

We also need to see your Application and Global firewall rules.

hmm yes it’s home. I have the firewall on safe setting and the defender disabled.

You can make home a trusted network using Stealth Ports Wizard. Go to Firewall → Common Tasks → Stealth Ports Wizard → choose Define a new trusted network, stealth my ports to EVERYONE else → next → choose I would like to trust and existing My Network Zone → choose home in the drop down menu below → Finish.

Did this help?

Forgot about this thread. Yes it helped very much. I added this on every computer. Although I still have a problem. I can Share Media (using windows media player) on the laptop to me, but when I try to share me to the laptop it will not work… It shows me in the Windows Media Player on the laptop but just says “No files…”. Any idea why?