Comodo blocked list?

Another question. I have noticed a number of installations I’ve tried to make over the past few months where I was getting the message ‘not a valid Win32 application’. I always wondered if it was something to do with comodo.
Today, I was running a program called Auto Gordian Knot which I’ve used for some time. It was working fine a couple of days ago. For some reason today, it now gives me the ‘not a valid Win32 application’ for one of the .exes within the programme. I reinstalled it and even upgraded to the latest version, but the same problem. Then I found this page on a messageboard where someone had the same problem with IE. They put it down to comodo blocking it.

I’m wondering if my auto gordian knot has somehow gotten on comodo’s blocked list, and if so, how do
I locate it and unblock it?

Go to D+\Advanced\Computer Security Policy and look through the list till you find Gordian Knot. Then right click edit it to trusted if it is blocked.

if I were you I would use DivX instead.

Well I don’t know. I’m new to DVD ripping and converting. I’m transferring old VHS tapes of mine to DVD. I know how to rip them to my hardrive with DVD shrink, and then auto gordian knot is able to then convert to AVI and you can select what size and quality you want the movie. Do you know of another or better program which does this? I may have to join the auto gordian knot forum otherwise and ask them about this win32 problem. Or maybe there’s some files in my registry which need clearing.

I’ve been trying for ages to sort this out with no luck. I did find auto gordian files and exes in the list you pointed me to. There was nothing that appeared blocked but I made everything a trusted application. In particular, the main autoGK.exe I made as a trusted application. Then when firing up AutoGK, D+ appears with choices again, even though I already made it a trusted application. And the choices don’t even include ‘trusted application’. Here is a screenshot.

When I select installer/updater or windows application, I get the ‘no valid win32 application message’. When I select’ isolated application’ I don’t get that message and it looks as though the program will work. But it doesn’t. I then disconnected my internet, shutdown comodo, uninstalled and reinstalled autoGK and then ran it. Again, ‘no valid win32 application’. I have no idea if this is to do with comodo or not. But it seems funny that comodo affected it in someway when selecting ‘isolated application’. ??? Have you heard of this ‘no valid win32 application’ message being a problem before with comodo for other people?


Your screenshot shows that the GK application is trying to start something called CMD.EXE. CMD.EXE is the command line interpreter in Windows XP and Vista. GK uses several command line utilities to do its stuff and when it starts these, it calls CMD.EXE and the command line utility runs in the CMD.EXE memory space.

In laymans terms - the Gordian Knot application we see on the screen is really a graphic based front end to a handful of command line utilities. When you set up a video conversion job in the GK application and tell it to start, what it is actually doing is taking the options you’ve selected in the graphical front end and sending them as parameters to the command line utilities that will actually do the work. The command line utilities need to run in a sort of DOS mode, which is established by invoking CMD.EXE and this then runs the command line utility with the parameters we defined in the pretty front end.

What you should have done when you got the alert in your screenshot is select ALLOW and make sure REMEMBER is selected. This would stop is particular alert re-appearing.

Hope this helps,
Ewen :slight_smile:

What may also work for this class of applications is to make it an installer or updater and tick remember. That program class is allowed to execute other programs without a popup.

Thanks for your replies, panic and sded. Makes no difference even with ALLOW. And REMEMBER was always selected anyway. It still comes up as no valid win32 application when clicking ok on INSTALLER/UPDATER. Then when I go back to look under Computer Security Policy, it changed it from ‘Trusted Application’ to ‘Custom Policy’.

Anyway, I’ve now found a better program than Auto GK. :slight_smile:

Still, it would be nice to know how fix this problem. But I’ve no real idea if it’s a comodo problem or something else. Certainly though, I have noticed a few applications which gave me no valid win32 ever since upgrading to V3.