Comodo BackUp Stops Working

I have CBU 2.2.127000.12
Comodo Internet Security 3.14.130099.587
OS Windows 7

When I try to backup complete registry or customise registry, at stage 6 a pop-up appears

Windows will diagnose problem and report back (or similar wording)

The only option is to exit. All other backup options are working with the Windows 7 set up.

I have the same CBU set up on Windows XP and everything works properly.

Is there a compatibility issue with Windows 7 registry backup or some other solution to this ?

Well i run that option on win7 and dont have problems apart from the file permission issues personally.

I have three scheduled backups set up at different times of the week. Two of them work just fine and send an email notification. One of the crashes every time.

I ran the one that crashes manually and it ran to completion. However, when run by the scheduler, I end up with the “Comodo Backup has stopped working message” as described above.

It was scheduled to run at 4:00am this morning. There is an error entry in the Windows Application log at 4:00:06. The error is:
Faulting application CBU.exe, version, time stamp 0x4b461c12, faulting module CBU.exe, version, time stamp 0x4b461c12, exception code 0xc0000005, fault offset 0x00000000001de940, process id 0xde8, application start time 0x01cae516782bf3d4.

The two backups that work are:

  • Music files - [Files and Directories] - 13 gig backup
  • Thundirbird - [Email Accounts] - 275 meg

The one that fails is:

  • Personal files and data - [Files and Directories] - 75 separate 250 meg files
    I also received the error before attempting to separate the backup into smaller chunks.

Hope this helps figure out what’s going on. Let me know if I can provide other information.


thanks for the information.
I tried to run Customise Registry manually and got another response:
“Initialising Registry Hives Backup
Retrieving the registry hives path failed
Backup process failed with code 4”

When I tried Customise Registry again running separate backups for Current User, Local Machine, Users and Current Config
all backups said they completed successfully although an awful lot of
“key not safe to backup (skipped)”
or “access denied to HKey” appeared during process.

Should I be worried that there is something wrong with registry ?

Windows does not like restoring those keys, even if their values remain the same.
There is nothing wrong with your registry.


I get the same problem when I try to backup the entire registry. I get “Retrieving the registry hives path failed. Backup process failed with code 4”. I am running 64-bit Windows 7 Enterprise, Spybot, Symantec Endpoint Protection 11, no other backup products. Am I doing something wrong? I have no problem doing a Disks, Partition, MBR backup.


Hi Stew

You are not doing anything wrong.
On some Windows 7 systems, some registry hive files have non-standard paths, for example “\.\HarddiskVolume1\boot.bcd”
This is the cause of error with CB 2.2
This issue was fixed in CB 3.0, which is now in BETA stage.
You can try it here:


Wow! Thanks for the quick reply! Great support!