COMODO Backup 4.1.2 - Bug Reports

Please post all bug reports & BSOD’s here.
Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Other Backup & Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • if the issue is a BSOD, please post all the dump files in \Windows\Minidump folder (you can compress them)
  • if the issue is a crash, program stops responding or freezes please see this topic
  • if the issue is an error (not program crash or freeze) please run the dbgInfo.bat in installation folder and post the resulting cbu file.
  • Any other Additional Information (for example, any non-default settings used);

Inconsistent services naming over multiple Comodo/COMODO products
Missing services descriptions

  • Windows 7, x32 Enterprise
  • CIS 5.10, CTM 2.9b
  • Open services.msc and look at the other Comodo services installed
  • N/A
  • N/A
  • N/A
  • N/A
  • N/A

[attachment deleted by admin]

XP SP3 - 32 bit

Steps to reproduce:

  • Launch 4.1.2
  • select “Backup”
  • change “Backup Format:” to ‘Simple Copy’
  • click [Add Folder]
  • in Browse For Folder, click “+” expanding My Computer–>BOING! Error

“Comodo Backup main executable has encountered a problem and needs to close. Yada, yada.”

Here’s the error signature:

AppName: cbu.exe AppVer: 1.0.0667 ModName: shell32.dll
ModVer: 6.0.2900.6072 Offset: 0008ebca

+1 but in Windows 7 x64

  • Your Operating System (and whether it’s 32bit/64bit);
    Windows 7 x64 SP1

  • Other Backup & Security Software Installed;
    Avast 7

  • How you produced the problem;
    Unable to select path when creating an incremental backup selecting a specific base.

  • How you tried to resolve the problem;
    Not possible since the selecting window only allows me to select the hard disc but not the folder where the .cbu file is stored

Please post a screenshot with the specific base issue.


Please create a dump file when the issue happens.


The issues will be fixed in next release.


Sorry Emanuel but unfortunately I’ve uninstalled 4.1.2 version and switched back to
It’s easy for reproduce and there is no need for screenshot since CBU doesn’t display anything. In fact this is the problem. If you want to select a specific base in incremental backup, CBU first ask you the hard drive where the specific base is. Then, an empty window is displayed instead of the folders of that drive so it’s impossible to select the .cbu

Thank you for posting back.
We reproduced the problem. An update will be available soon to fix this.

I’ve been testing 4.1.2 to see if it is what I want long-term. Everything seems good except for email notification. Test doesn’t work and there seems to be some sort of ?parsing? error messing up the notification settings. As requested here is my info;

Operating System: Windows Server 2008
No other backup or security software running (for test purposes)

Created a daily backup task with email notifications on success or failure (Capture1.jpg), all seems well, the backups run successfully but no email is sent.

In Comodo Backup, went to Shortcuts, then chose to edit the backup. Choosing “next” until the notification options come up, I can see that all text entries have the last character truncated (Capture2.jpg). Even if I re-add the characters and re-enter the password, click on “Send test message” returns a “Test message could not be delivered” message.

As a work around I attempted two things. First was to find the registry entries for the backup and manually enter the characters there. However it appears the password entry was affected as well, and the password field isn’t plain text. Second attempt was to add an extra character to each field (Capture3.jpg). As expected, after saving and returning to edit it again, the extra characters were truncated. However, it appears to have affected the password field in a different way and adding an extra character there makes no difference.


[attachment deleted by admin]

problem wiht comodo start after instalation. widow 7 pro 64bit. location lithuiania (same local settings in control panel → regions)
after start opens error window “could not open language file. plz reinstall the application” and thats all.
reinstall dont help. why it dont use english instead by default ? and wish to have same task sheduler like it was in 1st version. it was more user friendly and clear rules creation - what program will gona do when and so on…

Version: Comodo Backup
OS: Windows 7 x64 SP1
Regional Settings: English (Australia)
Special notes: Via symlink folder. Extensive use of symbolic links in
…\Users\ folder including …\AppData\Local\Temp\ Folder

Situation 1:
Attempting to create a differential backup choosing specific base from
My Computer.

Unable to browse past drive root. Copying .CBU file to root directory
and selecting it gives error: “Invalid Path”

Attempted Solution 1:
Attempted to manually input file path. Clicking next gives:
“Select at least one item to backup.”

Attempted Solution 2:
Created a shared folder and copied the backup to that folder.
Attempted to choose specific base from network share. Detected file.

Desired Fix:
Fix the inability to browse past drive root and select differential base


Situation 2:
Save backup shortcut using Attempted Solution 2.

Problem Primary:
Running the shortcut fails to detect network path and proceeds to
perform a full backup instead of a differential with selected base.

Desired Fix:
Network paths are searched correctly and differential bases on network
paths should be detected.

Problem Secondary:
Edit the shortcut. Change “From Network” to “From My Computer”.
Select a drive. Attempt to go “up” one folder crashes.

Desired Fix:
No longer crash upon editing shortcuts and browsing within program.


Other Comments and Requests:
o Allow an option to prevent NTFS symbolic links, hard links, junctions
from being parsed in full (rather only their “information” is copied).
Limited testing shows some good circular reference handling
characteristics. Need further testing.
o Once I had created a backup shortcut. Ran it in full. Tried editing it
after and the program kept crashing. I’ve since deleted the shortcut,
but now I’m faced with the inability to select differential backup