COMODO BackUp 4.0.3 BETA4 Bug Reports

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Other Backup & Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • file system (FAT32/NTFS/…)
  • All log files;
  • does Diagnose says the application is installed correctly? (“Diagnose report.txt” in %TEMP% folder)
  • User Account Control On/Off ?
  • Any other Additional Information;

Please make this hard drive scanning that CB does an opt-in feature, and provide a way to disable it completely. Every time I boot my computer, this thing slows my computer for up to half an hour as it scans my hard drives incessantly.

But it doesn’t end there. Even after the annoying post-boot scanning, navigating folders is more sluggish, as “Comodo SynchronizationService” is doing something every now and then. Additionally, if I launch CB and leave it running, it keeps trashing my hard drive accessing C:\WINDOWS\system32\config\software.LOG for no apparent reason. I used Microsoft Process Monitor to verify this. All this makes CB practically intolerable, and I have to uninstall it.

I don’t need CB thrashing my hard drives to locate media and documents. I can only imaging how much worse things would be if I actually enabled antivirus software.


OS: Windows XP SP3
Other backup and security software installed: Acronis True Image WD Edition; FBackup 4
Other security software installed: Avast antivirus [COMPLETELY DISABLED]
How you produced the problem: Install CB 4.0.3 Beta 4
How you tried to resolve the problem: Uninstall CB
does Diagnose says the application is installed correctly?: No such report exists

Minor bug 1: default COS backup target path is not a COS path.
Minor bug 2: pressing Back button at backup target will reset the COS path.

Vista 64 bit, i don’t think rest is applicable for this minor bug.

Description: when you select backup target the Comodo Online Storage is selected as default. However, the file path is my older backup target location, which looks like “D:/Windows Mail_full_mail.cbu” (so, it is not a COS target).
There’s also a small issue if you click Back to modify source. In this case the COS path will be reverted back to the last used (?). Click Back, then Forward.
To resolve this issue: selected local, then COS target again.

Um, Emanuel, i got random freezes (at random steps). Do you think the cbu report will be enough? CPU usage az freeze: 0%, memory usage: 15 276K. I got no error messages. I haven’t had this problem with earlier releases.
I wonder if this helps (Windows application log):

Napló neve: Application
Forrás: Application Hang
Dátum: 2011.07.29. 21:28:08
Szint: Hiba
Kulcsszavak: Klasszikus
Felhasználó: n.a.
Számítógép: RECOVERY-XS
A(z) CBU.exe program (verzió: kommunikációja a Windows rendszerrel megszakadt, ezért a program leállt. A hibával kapcsolatos további információkért ellenőrizze a probléma előzményeit a Problémajelentések és megoldások alkalmazásban. Folyamatazonosító: 1098 Kezdés: 01cc4e245f020025 Befejezés: 1015
Esemény XML:




Translation for first sentence:
The CPU.exe program’s communication with the Windows system has lost, therefor the program has stopped.

Another entry (1st hang):
A(z) CBU.exe program (verzió: kommunikációja a Windows rendszerrel megszakadt, ezért a program leállt. A hibával kapcsolatos további információkért ellenőrizze a probléma előzményeit a Problémajelentések és megoldások alkalmazásban. Folyamatazonosító: ce4 Kezdés: 01cc4e2314a62985 Befejezés: 183

The 1st happened at backup target, second at Backup Settings. I can’t reproduce the problem at the very same location (this is random).

OS: Vista 64 bit.
Problem described above
I couldn’t resolve the problem, i answered shut down for the Windows request.
No diagnose problems.
UAC off.

EDIT: i had an internal error 43. I let the program run in the background and was typing into this forum, i’ve switched back and there was another hang. As i see, this freeze comes up after 5-10 minutes.

Macro usage failed (used MACRO3), that’s the reason for that 43 (my guess, hence i left out everything else).

No, what is needed is a dump (Task manager → right click on CBU.exe → choose ‘create dump file’)


From the help files:-
“Mount backup everytime Windows starts - Instructs the application to repeatedly mount the backup as virtual drive with the selected drive letter, every time windows is started. Select this option if the backup is scheduled once and going to be updated periodically.”

Unfortunately when I try this, the mounted backup doesn’t mount on restart.

Windows 7 Home Premium
UAC off.
Backup stored on an USB drive.


I can’t even get it to launch, crashes every time.

  • Your Operating System (and whether it’s 32bit/64bit): Windows 7 Ultimate x64
  • Other Backup & Security Software Installed: Avast Internet Security 6
  • How you produced the problem: Ran the program.
  • How you tried to resolve the problem: Tried admin & compatibility modes.
  • Screen-shots with the error (if any):
  • file system (FAT32/NTFS/…): NTFS
  • All log files: Don’t seem to have any.
  • does Diagnose says the application is installed correctly? (“Diagnose report.txt” in %TEMP% folder): I don’t have this file.
  • User Account Control On/Off: On.

I have tried 3 different attempts at backup. With each I have attempted to backup My Documents, a 10.9GB file, to DVD.
Attempt 1. I tried to just select the My Documents from the backup list but this would not start.
Attempt 2. I selected the custom mode for the backup using the simple format output, differential type, the source from the list and the output as the DVD. It would not allow me to check the box to erase the disc before starting so I ensured that I used a new disc. The backup failed immediately with Code 9 (internal error).
Attempt 3. I used the same settings as above but selected a CBU output format. The backup read and listed files for 30 minutes then displayed a message that the backup exceeds the size of the output file. It then started copying the first chunk to disc. This continued for 70 minutes and then the backup failed with the message “Backup failed with code 163 (IMAPI recored speed mismatch). It does say “recored” although it probably should be “recorded”. I have taken a dump at the point of failure but this is 122MB and is larger than the permitted attachment size.
Apart from the fail there are two other points that are worth making.

  1. The concept of reading the file for 30minutes and then starting the disc burn means that the overall time taken is extremely slow. In Comodo version 1 the read and write are conducted at the same time.
  2. During the read phase there is a progress bar that shows the progress of the job and there is an estimate of the time remaining. Once it starts writing to the disc the progress bar returns to zero and the overall job estimate stays frozen for the duration of the disc writing phase. There is nothing to indicate how long the disc writing phase will take.

Operating system is XP SP3
AVG and ZoneAlarm installed