Please try to set some dummy values for username and password fields.
For example username “NONE” password “NONE”


Hi again :slight_smile: I hope i’m not very annoying.

Sheduled job and exported script working different ways (or not working at all).

create new shedule and export script:
Step 1: Backup/New Backup/Incremental - Make new backup

) An incremental backup plan will create a full backup if a backup base doesn't exist, otherwise backup created will be incremental. The same for differential.

All other steps like usual, from where, to where …
Step 5: export to script “” (attached), schedule a backup, frequency - manual, save schedule.
Still Step 5 - Backup now, working.

Close CBU

Run script - “C:\Program Files\COMODO\COMODO BackUp\cbu.exe” /script “path_to/” - not working, because script has empty /parent_backup_path “” parameter. Lets make this like /destinationpath “path_to\tmp_inc_files.cbu”, rerun script - it working now.

Delete backup file path_to\tmp_inc_files.cbu, rerun script - it not working. Clear parrent backup path to exported version - script not working, not creating Full backup, as suggested.

Strange is, that you may run CBU, go to manage, select sheduled job we made early (and exported script) - it works. Backup is - makes incremental, backup deleted - makes full.

!ot! in script found parameter “destinationtypediskfile”, and thought this is bug too, because didn’t find this one in manual :slight_smile:

P.S. Above sheduled job not executing, when using /runbackup from console, but working from CBU

Scheduled backup jobs can be immediately run from the command line interface by using the /runbackup command followed by the ID number of the target job.

Best regards, Nihila

[attachment deleted by admin]

Apology for incorrectly reporting problem with mounting images: my BU images include Track0 & MBR and I had not selected to mount the backed-up partition via the drop-down menu button. Guess I should have read that bit of the manual!

here is a bug report and a link to a pic

here is the orginal topic:;new#new


[attachment deleted by admin]

No joy. Also had a failure to execute a scheduled diff backup this morning. The first one last weekend worked fine and created a new CBU file. The attempt to create a diff backup based on that one is shown in the attached screenshot.

EDIT: Email still failing as noted in the screenshot.

[attachment deleted by admin]


Thank you for reporting the problem. It will be fixed in the next release. If you want you can manually perform a differential backup by selecting the “choose existing backup” option from backup step 1.

Sorry for the inconvenience.

My CB 130 doesn’t work properly at windows 7 32 professional. It doesn’t open in main window. After reinstallation it generated diagnostic text:

19.12.2010 21:34:43 Comodo BackUp 3.0.171317.130
19.12.2010 21:34:43 Checking if restart is needed…
19.12.2010 21:34:43 No restart needed… OK!
19.12.2010 21:34:43 Verifying your windows version…
19.12.2010 21:34:43 32bit…
19.12.2010 21:34:43 Windows XP
19.12.2010 21:34:43 Windows version check OK!
19.12.2010 21:34:43 Current user has administrator privileges!

19.12.2010 21:34:43 Checking if Synchronization service is running…
19.12.2010 21:34:43 Synchronization service is running!
19.12.2010 21:34:43 Online Storage service is running!
19.12.2010 21:34:43 Checking CBU.exe integrity…
19.12.2010 21:34:43 CBU.exe is ok!
19.12.2010 21:34:43 Checking CSE.exe integrity…
19.12.2010 21:34:43 CSE.exe is ok!
19.12.2010 21:34:43 Checking vss_xp.dll integrity…
19.12.2010 21:34:43 vss_xp.dll is ok!
19.12.2010 21:34:43 Checking vss_vista.dll integrity…
19.12.2010 21:34:43 vss_vista.dll is ok!
19.12.2010 21:34:43 Checking vss_s2003.dll integrity…
19.12.2010 21:34:44 vss_s2003.dll is ok!
19.12.2010 21:34:44 Checking SynchronizationService.exe integrity…
19.12.2010 21:34:44 SynchronizationService.exe is ok!
19.12.2010 21:34:44 Checking COSService.exe integrity…
19.12.2010 21:34:44 COSService.exe is ok!
19.12.2010 21:34:44 Checking ShellExtension.dll integrity…
19.12.2010 21:34:44 ShellExtension.dll is ok!
19.12.2010 21:34:44 Checking cbufs.sys integrity…
19.12.2010 21:34:44 cbufs.sys IS DAMAGED!
19.12.2010 21:34:44 Checking BDisk.sys integrity…
19.12.2010 21:34:44 BDisk.sys IS DAMAGED!
19.12.2010 21:34:44 Checking CBReparse.sys integrity…
19.12.2010 21:34:44 CBReparse.sys IS DAMAGED!
19.12.2010 21:34:44 Checking cbvd.sys integrity…
19.12.2010 21:34:44 cbvd.sys IS DAMAGED!
19.12.2010 21:34:44 Checking cbvdbus.sys integrity…
19.12.2010 21:34:44 cbvdbus.sys IS DAMAGED!
19.12.2010 21:34:44 Checking cbunat.exe integrity…
19.12.2010 21:34:44 cbunat.exe IS DAMAGED!
19.12.2010 21:34:44 Checking if BDisk.sys is working properly…
19.12.2010 21:34:44 BDisk.sys is working properly!
19.12.2010 21:34:44 Checking if cbufs.sys is working properly…
19.12.2010 21:34:44 cbufs.sys is working properly!
19.12.2010 21:34:44 Checking if CBReparse.sys is working properly…
19.12.2010 21:34:44 CBReparse.sys is working properly!
19.12.2010 21:34:44 Checking if cbvd.sys is working properly…
19.12.2010 21:34:44 cbvd.sys is working properly!
19.12.2010 21:34:44 Checking if cbvdbus.sys is working properly…
19.12.2010 21:34:44 cbvdbus.sys is working properly!
19.12.2010 21:34:44 Checking windows task scheduler functionality…
19.12.2010 21:34:45 Windows task scheduler is working OK!
19.12.2010 21:34:45 Diagnostics detected some errors (see uppercase errors)!

Looks like CB thinks you have Windows XP. This is the reason for diagnostics error.
Please go to regedit, open registrykey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion and let me know what is the value for “ProductName”.


XP heh on second computer! I have Windows 7, Emanuel, I know exactly what I’m writing :slight_smile:
Here is my control panel’s jpg:

The problem is with CB not my system sorry :slight_smile:

I know you have Windows 7 that is why I requested you to look into HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion with regedit and let me know what is the value for “ProductName”.


Ok :slight_smile:
Windows 7 Professional

Do you have any other security programs installed that might trick CB into thinking that is running under Windows XP? Maybe firewalls or programs that use sandbox method ?


Only Kaspersky Internet Security 2011

There’s a screenshot from my comodo CB:

it can’t open in normal window mode. Opens only at full screen mode and with announcer that “problem with comodo were detected”

The attempt to backup my user profile under Windows XP resulted in a fraction of the files selected being backed up by Comodo Backup (but all the directories) and, on restore, being backed up to a different directory structure! Since I’ve tried to edit the original backup, Comodo Backup continually crashes (after pressing next at the ‘select source directory’ step).

So, these are actually two serious problems.
Firstly. the script, ‘’ I generated for this backup does not contain what I would expect: if I select '‘C:\Documents and Settings\sandokanfirst’ and then deselect some subdirectories, I would expect only a list of deselected entries. Instead CBU gives me a list of ALL the directories. On a restore, these are presented in a flat directory and are mostly empty.
I will attach the .cbs scriptas a .txt file.

Secondly, the crashes. I will attach a debug.cbu file and the ‘8de7_appcompat.txt’ file Microsoft keeps asking me to send them.

I use a fresh installation of COMODO BackUp “3.0.171317.130”

My system data:
Windows XP Home Media Center Edition Versie 2002 Service Pack 3 (Dutch version),
32 bit,
User Account Control: Off

I’m running Comodo CIS, 5.0.163652.1142, Virus Signature Database Version 7171

additional info:
I backup to a NAS
and have installed CBu to the D:\ drive (which hopefully is irrelevant)


[attachment deleted by admin]

This is not a Comodo Backup bug, it is a bug in a Help page for Comodo Backup.

Go to Comodo Help

Read the bottom of the help message. There is some crucial information missing that is visible only if you look at the HTML code (i.e. an error in the HTML code prevents the text from getting displayed).

Browser is Firefox 3.6.13.


Please right click on CBU.exe file in installation folder and choose Properties, choose Compatibility and make sure that all options are unchecked then click “Change Settings for all users” button and make sure all options are unchecked.



You should use exclusion filters to exclude some folders.
The folders you see are empty because you used as inclusion filter “*.bak”

The crash issues will be fixed in next release.


Thanks a lot! It all makes sense now. I should have RTFM. Especially the inclusion filter works in a logical fashion, now that I think about it. I’m a bit less happy with the exclusion filter, being used to ‘ntbackup’ which shipped with Windows XP, where you could just deselect folders you didn’t want to include.

I’m sorry to say that for now, I had to uninstall CB because of the continuous crashes, so I’m eagerly awaiting a new release. Keep up the good work, thanks again,

When editing an existing custom profile, there is no icon to change the schedule.

However I must make my compliments.
I’ve tried different SOHO backup software (Cobian, GFI Home 2009, Uranium, etc …) and Comodo Backup 3.0 for now seems to be the one with the best balance between functionality and ease of use, although it shows some sins of youth.

Keep it up!

Strange behavior for Settings → Default Destination:
when set to H:\ the proposed path, for example, to backup the My Documents folder is H:\MyDocumentsBackup.cbu

But when it is set to H:\Backup the same path becomes H:\Backup\Backups\MyDocumentsBackup.cbu

Innocent youth :wink: