Comodo + AVG + eMail problem.


Having problems with Comodo Firewall & AVG Free Antivirus when reading mail.
Comodo doesn’t let AVG scan email messages.
I need to disable firewall to read mail.

What do I have to do to make it work?

Welcome to the forum!

Does the logs say anything?


Nothing in logs.

With Thunderbird, eMail never seems to get read (AVG eMail popup window stays there forever).
With Outlook express it does get to read mail after a while.

It isn’t normal, previous to using Comodo it worked fine.
In fact, if I set Security Level to “Allow All”, it does read mail Ok.

If CPF is blocking something & it is not in the log, there is only one way that can happen. You have a silent blocking rule in the Network Monitor. To test this, temporarily set all your blocking Network Monitor rules to “Create an alert when this rule is fired” (edit rule to change this). This way you’ll find out which rule is blocking it.

Not a rule problem.

In fact, if I disable AVG eMail integration, it worked fine.

I think it has to do with one app intercepting another one or something.

However I have disabled Application Behaviour & Analysis, as well as Advanced stuff, but still doesn’t work.

It must be some problem with Comodo & AVG.

Anyone using AVG with Comodo?

I’m sure there are other AVG users out there using CPF. AVG is a highly regarded & popular AV program.

But, CPF doesn’t alter or redirect communication packets. After inspection, it either allows them or blocks them. Assuming all the AVG components have the proper authorisation (this may mean allowing each relevant AVG component do whatever they wanted & to be even allowed to open invisible connections if required), then CPF will not interfere with their operation. And even if CPF did interfere, then it would only be to block.

Edit: If you agree, I’ll move this topic to the Help section. More people will see it there (re: AVG users using CPF).


Find the application monitor rule for the AVG email scanner application and double click it. Click the Miscellaneous tab and select “Skip advanced security checks”. Reboot and you should be OK. The problem is caused by the slight delay that CPF introduces to the scanner checking mails and AVG doesn’t like to be interrupted.

Hope this helps,
Ewen :slight_smile:

Yeah, that made it work! (B)


I had exactly the same problems and this solution also worked for me :■■■■

Another great one by panic

thanx a lot



FYI…this fix was also in the knowledgebase of the support system.
I modified it slightly today from the details in this thread, but essentially it identified the “Skip advanced security checks” in relation to AVG.