Comodo AV stalls during scanning

Sorry if this is in the wrong place - new member.

I am now getting this problem on my laptop.

Windows XP SP3, CIS version 5.10

Stall occurs at about 61% through scanning of the System Volume Information folder which is protected and cannot be viewed.

If I remove this folder from the scan list everything works fine.

By monitoring the scanner dialogue box I established that the stall was occurring at the following positions

D:\systemvolumeinformation_restore{long licence number}\RP513\

Objects scanned before the stall occurred = 88026

Time to stall from start of scan = 30 mins.

Any help appreciated.


System volume information is a folder where Windows system restore points are located, and CIS may be stuck there becourse that file is dameged or CIS tries to upload it to cloud but can’t get permission (that folder has very strict permissions)… Those are just my assumptions though. Try to delete your current system restore points, and create a new one after that, then try the scan again, it shouldn’t stuck there after that.

Thanks for that. However I have no idea how to delete the latest restore point since I can’t get at the folder. Tried deleting all except the latest via system cleanup but when I try and run CIS on the folder it stalls almost immediately which I guess is because the corruption is still present. Anyone know how to delete the latest restore point so I can then create a new clean one?


Hi PeterG,
Create a new restore point and then use the disc/system clean utility to remove all except the freshly made one.

Caution after the following no restore points will be available.
Or temporary disabling system restore will remove all restore points.
Don’t forget to re-enable after if desired.

OK. I tried that. However the corrupt file (as in my original post) is replicated into the new restore point so I still can’t scan the volume. CIS now stalls almost immediately when I scan the restore volume. The volume is so heavily protected that I don’t know how to remove the corruption. Any further ideas appreciated.

Could you please follow the methodology I suggest in How to Know If Your Computer Is Infected in order to make sure that your computer is not infected?

This would remove one possible explanation.

A brute force method of deleting the current system restore point is to disable system restore. This will remove ALL system restore points.

If you then re-enable system restore, it will create a new restore point.

Ewen :slight_smile:

Many thanks to ‘panic’ for putting me on the right track. I did what you suggested and disabled system restore. I then rebooted and the disc was active for a long time deleting the restore points. I then created a new restore point and followed that with a successful scan of the restore volume. Just to be 100% certain I then ran a complete system scan which completed successfully - first time in about 3 weeks.

Grateful thanks to all contributors for taking the time to help. Keep up your good work.

Problem now closed.