Comodo AV and Microsoft Word

I am having a special problem with Comodo AntiVirus and Microsoft Word.

Each time I use Comodo AV as part of Comodo Security Suite

I get problems using Microsoft Word. Particularly I cannot save in MS Word.

When Comodo AV is on and I try to save a document in MS word I get:

“Word Cannot complete the save due to a file permission error”.

When I disable Comodo AV - this exact problem immediately disappears.

No other program is giving me this trouble other than the Comodo AV.

Does anyone have any clue or idea as to how to solve this problem?

Sincerely Peter Petersen - A Happy Comodo User (and MS Word user)

I haven’t installed CIS as AV only. I understand though that Defense + would be enabled in the AV only as well. Go to Defense + - → Advanced → Computer Security Policy → look up winword.exe → make it a trusted application.

Thank you for your answer. I have unfortuantedly already tried this.

I read the comodo help file and tried this, but it did not work.

Winword.exe is set as a trusted application, but to no avail.

I have read that other AV’s have the same problem with Word.

I just thought that there was a way to get around it with Comodo.

With some AV’s (like Kaspersky) there are settings that can be adjusted

within the AV so a conflict between the AV and Word can be avoided.

I am really happy with Comodo though and gotten used to it, so I am

wondering, if there are any settings in Comodo that might do the same?

Sincerely Peter Petersen

It may be a problem with the permissions for explorer.exe. Delete the rules for explorer.exe. Does that help?

There were two policies for the Internet Explorer.

I delete them both. Then I rebooted the computer.

The problem was, however, still there in Word.

To be sure I then disabled the AV in Comodo.

and the problem then disappeared in Word.

So like before the Comodo AV still conflicts with

the file saving function in MS Word.

You deleted the rules for Internet Explorer not for Explorer (explorer.exe). Would you mind trying with the AV on?

Sorry, my mistake.

I have now deleted the policy for

explorer.exe (not iexplorer.exe).

However, the same problem still exists.

I did not specifically state to delete the rule under Defense +. Was the rule you deleted the one under D+?

When deleting the rule for explorer.exe does not work try deleting the rule for winword.exe. Does it happen with AV enabled and does it happen with AV disabled?

I have now done the following:

You have not specified where to delete the rule so

I have deleted the rule for explorer.exe and winword.exe

in firewall > advanced > network security policy and

in defense+ > advanced > computer security policy.

Then I tried saving in Word and this was denied.

I then disabled the Anti Virus in Comodo

in anti virus > common settings > scanner settings.

Then I retried saving in Word and all went okay.

This means the Comodo Av is still blocking Word.

try this D+ tab at top → my blacked files, is there anything there? Also look in these places and let me know, my own safe files and av tab at top → scanner settings → exclusions anything there? Let me know what you find, I just tried repeating with word for me and everything is fine, I have a feeling something got blocked by accident.

weird, try this, right click on the comodo shield in the task manager, go to configuration and pick a different one. Now try using word again, if it works there must be something in one of your rules blocking word. You will basically have to go through all of the rules to see where it is.

just curious, Which microsoft office are you using 2003, 2007 or the new 2010 preview???
also do you have 32x or 64x ???

Answer to languy99:

I went into the Task Manager and I found cfp.exe.

I right clicked on cfp.exe and I got a list where I could

  1. End process, 2. End process tree, or 3. Set priority.

I am unfortunately not so familiar with Task Manager

so I couldn’t find the configuration function you mentioned.

Answer to jay2007tech:

The Microsoft Office version I am using is 2000.

The XP version I am using is:

XP Home Edition 2002 – Service Pack 3.

Perhaps this error has been corrected in the newer

versions of Microsoft Word such as 2003 and 2007.

@ jay2007tech

MS Office only comes in x32 (x86) flavour. MS did not release any x64 versions of this suite.

I am also experiencing a problem running Word with Comodo AV. We do not have the firewall installed. We are using Word XP with WIndows XP Professional SP3. I tried deleting the explorer.exe rule but that made no difference. We basically used to default settings when installing Comodo AV. Any more suggestions?


Try deleting the rule for winword.exe as well.

Have exactly the same problem with the same symptoms and tried the same resolutions with the same lack of success.

Can’t find winword.exe listed anywhere in any Comodo setting but when I disable Comodo AV I can save files to Word.

Worst thing is, with Comodo AV enabled at any level it will delete the .DOC file and it can not be recovered when you try to save it and the “Word can not complete the save due to file permission error” error pops up.

This problem is far too dangerous to leave Comodo AV activated and going unprotected is almost as dangerous.

Anyone have any ideas?

Egemen said yesterday there is an update upcoming in which several problems with the AV will be solved:

Let’s hope this one is solved as well.

Found a post about this dated November 22, 2008

This is not an insignificant problem. An incompatibility with a widely used app or suite can be a company killer.

I can’t believe this has not been addressed and FIXED.

This problem is far too dangerous to leave Comodo AV activated and going unprotected is almost as dangerous… a little more than HOPE would be nice.

Ditto. In the meantime, when the error occurs, the user CAN hit “retry” on the error message, then essentially “Save As” the .doc. But as at least one of my users has done, if they, out of frustration, without thinking just quit, then they’ve lost their document (the open copy they were working on AND its original saved version).