COMODO Application Agent is not running....Help!

I am running Vista Home Premium, 64 bit. I have COMODO Firewall v.3.5.57173.439. I have had it for about one month, and everything was working fine, and all of a sudden I saw a red circle with a line through it on the COMODO icon in my system tray. I opened COMODO and under “System Status,” and it says “COMODO Application Agent is not running.” It says to run the diagnostics utility to fix the problem. When I run it, it says “the diagnostics utility did not find any problems.” Can someone tell me what may be wrong, or what I should do to correct this? Thanks.

Note: Under Control Panel > Administrative Tools > Services, COM + System Application is set to “Manual.” COM stands for “Component Object Model.” Does that have anything to do with my problem?

Since nobody was able to post an answer to my problem, I uninstalled COMODO, and then re-installed it, and it now works fine. I wish someone who knew the answer would have guided me what to do, so I could have learned something about COMODO, and why the Application Agent stopped running. I learn most things about software by posting in a forum.

Thanks for sharing your way of fixing this. :-TU

I had this problem myself on a computer, the reason for that was that the installation was interrupted and some files got damaged, did a reinstall as you, everything worked.

But it can be a number of things, theoretically you could have made CIS block the application agent from running.
It could also be a startup BUG… The COM + System Application set to manual has nothing to do with this however. :slight_smile:

Sorry I can’t be of more help. The main reason why you sometimes don’t get an answer is because people don’t know or people don’t have the time to check and answer every question, some of the mods has been here years and if you been with comodo that long answering similar questions like why is this, what is that, could get a bit bothersome. And they get nothing for helping out really, mostly they do it to be nice. But you already knew that. :stuck_out_tongue: :stuck_out_tongue:

Most likely it is a Windows (Vista) issue. I don’t recall this happening with XP.

I understand…Thank you very much!


I had the problem too and I’m using Windows XP. The solution to the problem is simply "stop Comodo (Exit) leave for 2-3 seconds and start Comodo. That solved the problem for me. :-TU

Good Luck! :BNC

I tried that, but it wouldn’t work…I’m ok now with the re-installation. Thanks though.

Unfortunately, it does happen with Windows XP. I have been fighting this for two days now. Occurs when CIS (AV & FW) installed, and also when only AV installed. Usually, after a boot, starts out OK, but soon drops into “Application Agent not running!”, with no obvious way to re-start the program. Running the diagnostic utility finds no problem with the installation (maybe its not an installation problem?). When the Firewall was installed, this “Application Agent not running” state also had the internet connection blocked. Aside from that, most things seem to be running. I was getting “learning” dialogs, “alert dialogs”, etc. and the machine is currently doing an AV scan eventhought the “Application Agent is not running”

This is an XP problem as well. I just tried the EXIT program and then ran it again and it seems to be OK. I thought after re-booting it would have fixed it, but it did not. I will see if this corrects the problem, but it would be useful to know what caused the problem in the first place.

I’ve seen this on XP Pro SP3 with the latest update (and only the Firewall active). The odd thing is that the cmdagent.exe program IS running in the task list! To exit, right-click the tray icon and select “Exit”. Then launch the shortcut for “Comodo Internet Security”. This did work for me.

Hi all

I’m a newbie to Comodo and had the same problem. A search came up with this post in the forums….and it worked for me. Thank you jrdorock

posted by jrdorock

I got the same problem and I fix it following the steps bellow:

  1. Run services.msc
  2. Right click on “COMODO Firewall Pro Helper Service” and choose properties
  3. Select “logon” tab and enable the service for the hardware profile
  4. Select the general tab and start the service
  5. Go to directory “C:\program files\COMODO\Firewall” and run cmdagent.exe
  6. Close CFP on tray and start it again

COMODO application is not running. I ran diognostics, but to no avail. Everytime I reboot, it comes up the same. I browsed the forum and somebody (and thank-you) said “stop the program…(click EXIT) and wait 2 to 3 seconds”
This worked.
I don’t know how to use a forum. I don’t know how to “POST” By no manner am I stupid, it is merely that I don’t understand the mechanics of using a forum. It is a strange and different way of logic of which I am unaccustomed.
I only got here by chance.
Could you please show me how to “POST”
…sincerely, rodot

rodot replies to himself: I figured out how to “POST” Also , I uninstalled Comodo completely and installed Comodo Firewall as a stand alone. The antivirus part was wrecking my computer; slowing it down to stupid. It seemed more interested in regulating every thing and interfering with every action I did offline and online , than in being a support. It was a huge hog. Now my computer is running faster.

With some regret I have uninstalled Comodo from my XP machine due to this ‘Application Agent not running’ business. This state of affairs seemed to manifest regardless of browser being used to include, at that moment in time, latest Firefox; SeaMonkey and Internet Explorer 8.

The above seemed to happen regardless of what was was going in the machine and seemed to be randomly generated often when away from the machine. Comodo Diagnostics fixed ‘it’ but then wanted a System Restart which became a pain.

The only software added during the life of the Comodo installation was some rubbish from ‘Paypal’ to do with Email Identification protection which, when installed, also seemed to be tied in to some McAfee component which placed itself on the desktop. Anything to do with McAfee seems to be the kiss of death on my machines over the last three to four years. The latter software was uninstalled.

Other software installed at about the same time as the Paypal nonsense was some website verification software, also since unstalled. Still however, the ‘Agent Application not running’ logo pops up so, feeling that my machine was not protected properly, I felt no alternative but to uninstall Comodo and install another firewall and antivirus scanner. Both of these at the moment seem to be stable.

I did, at one point, re-install Comodo but I did not use a proper ‘clean’ tool as you sometimes have to do with ‘Ahead’ / ‘Nero’ software to achieve a clean re-install.

Bye for now, bipbop333

SOrry to hear about your problems.

When you haven’t totally lost all hope try the following search for left overs from previously uninstalled secrutity programs.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

hi - thank you lordpuffer!! i had the same problem. so i stopped comodo for a few seconds restarted it and wam bam its working. thanks.
fh89255 :smiley: :-TU :BNC

sadly i have the same problem. the solutions arent’t really interessting for me, since i use only comodo for about the last five years, have no other sec software…so its a cmd problem!
the only way for me to use comodo right now, is to start the diagnostics right after rebooting, then close cmd and start it again. it then works properly, but not before…i have to do this every single time i start my pc.
re-installing does nothing!
to an unrelated topic cmd often blocks some programs associated with the explorer.exe without asking or anything. anytime cmd does that i have to reboot, too. following the above described procedure.
i even defined the associated programs as trusted apps but cmd blocks them anyways! no way to interfere…

to sum it up, since cmd updated to “premium” i am really unhappy with it. doesn’t work properly, has so freaking many problems that always lead to rebooting therefore leading to all the stress again.
in some cases from my friends, to whom i usually recommended cmd, they couldn’t even start their pc anymore, till they de-installed cmd per “safe-mode”.

please make a workaround! fix your problems and make cmd the great firewall it was before, cause as for now, its just so much trouble!

At a friend’s PC I encounter the same error. My personal updated CIS is running smoothly while at this PC I see the same cycle: Yellow exclamation mark error – diagnosis – error found – everything seems to be fine, but a restart is recommended – reboot – back to square one.

Sorry I have to tell this, I have the same problem on Windows 7 Ulitmate, version of CIS is 5.0.163652.11421.

After few minutes of running Comodo I can see this icon.

This issue appears together, with ask dialog for allowing processes and programs which I already allowed.

When I open Comodo, I can see that Comodo Application Agent is not running, turned off.

After running diagnostic, all seems to be OK.

For while helps to turn Comodo off a run again.

Cany anybody helps? I try uninstall and install again.

Sorry for screenshots in Czech.

After I reinstal Comodo Internet Security, the problem is back again >:( Because of ot is critical problem I have to stop using Comodo and install other product. If this bug will be repaired, please let me know.

I will be happy if I could return back to Comodo.