COMODO Application Agent is not Running! cfpconfg.exe Application Error

I’m running Windows XP Pro SP3 with Avast, everything worked fine at first, I don’t know if I did something, but my COMODO Firewall started showing the “COMODO Application Agent is not Running!” error.

So I tried to ran the Diagnostics Tool, which gives me this error cfpconfg.exe - Application Error “The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.”. So I click OK, nothing happens.

Frustrated, I try to reinstall COMODO from the start menu, I get the same error (0xc0000005), from the Add/Remove Software Panel nothing happens when I click the Change/Remove button.

I remove all the files and registry entries connected to COMODO, so I can install COMODO again. But I still get the same problem with the Application Agent and the cfpconfg.exe.

I also had Malwarebyte’s Installed, but never used it and uninstalled it before reinstalling COMODO.

So what could be the problem?

Well I reinstalled Windows because the problem(0xc0000005) started to appear with other programs too.

I am having the same issue, and I now cannot access SNDVOL32.exe aka Volume Control in the taskbar either.

Is anyone going to help? I don’t have the means to reinstall windows at the time. :frowning:

same problem here, Comodo won’t uninstall and won’t run.
After manual uninstall (removing registry keys etc), the installer works fine but same error appears.

There are various possible sources for 0XC0000005 as described here: How to Resolve Error Code 0xc0000005 - Instant-Registry-Fixes.org . See if the same thing happens without CIS as well. Check your Ram using Windiag and let it run for at least 10 rounds.

Then follow What to do if you’re infected - eXPerience Rev.3 to look for malware.

Please start your own topic with a clear problem description. This way your problem will the attention it deserves and this topic will not get side tracked.

There is also a clean up tool that can clean left overs when the installation is corrupt.