Comodo AntiVirus Problem

I just finished installing Comodo AntiVirus on my other PC and it’s fine, nothing to report. But I tried installing it on this PC, with some weird results. The installation was successful, I restarted my PC as I was directed to do. When I logged back in and opened up the program from the tray icon, it came up no problem, but all the buttons seem to do nothing. On my other computer, security settings were shown as being turned on, but on this one they are shown as “Refreshing”. Since all the buttons do nothing, pressing the “Turn On” button for the security settings has no effect. It seems like the program is unresponsive, but I can minimize/close it by the taskbar and access the right-click menu by the tray icon. In fact, just this second I got a pop-up message by Comodo AntiVirus in the bottom-right of my screen telling me its been automatically updated. I checked the program again and it still has the same problems. I’ve tried uninstalling, restarting the system and re-installing with no luck. It runs perfectly on my other computer.

Both of them are on Windows XP SP2.

Anyone have any ideas?

Hi 2Pro,

See this link.

CAVS 2 never made it out of Beta status, and no effort is being made by Comodo to keep it up to date. CAVS 3 is due any day (first in beta, then full release). Most moderators are advising to find a temporary substitute AV (i.e. Avira, Avast, AVG, etc.) until the new CAVS 3 is released.
I would download a trial install of one of the above, and wait for CAVS 3 release.

Good luck.


Well, I’m not sure most of us prefer that. Personally I’m in between. However, finding a solution to 2pro4show’s problem would be desirable. Since I don’t use CAVS I can’t really give any advice, though.


ps. welcome to the forum 2pro4show :wink:

Hi 2pro4show

It sounds like you have something conflicting with CAVS. What other security apps do you have running in real time? Did you try temporarily disabling them when installing CAVS? Do you have another mail checker running that could possibly cause a problem? Do you have another HIPS program running? Are the processes CavApp.exe and CMain.exe running? Is the service cavasm running and on automatic?

Let us know as much as possible and we will see if we can get it going for you.


I don’t think that’s the problem, JJasper. I have Comodo Personal Firewall and Comodo BOClean also installed and running, but that’s also the case on my other computer, and Comodo AntiVirus runs perfectly on that one. The processes you mentioned are running. I’m getting help on a malware forum at the moment, I’m pretty sure I have some sort of malware on it that’s blocking my use of Comodo AntiVirus.


OK If you need any more help let us know after you get the malware off.