Comodo AntiVirus for Linux update fails

I use Comodo Antivirus version 1.1.268025.1 for Linux on Scientific Linux which is/was based on Redhat Linux. For a year now updating worked just fine. All of a sudden, with the latest upgrade at file BASE_UPD_END_USER_v25651.cav , I get the following error message: “Failed to update the virus signature database. Please check your internet connection and try again later.” However, my internet works fine! I’ve even tried the recommended bash commands and reinstalling. Nothing get me past this one file noted above.
Today, the update button was able to get past BASE_UPD_END_USER_v25651.cav , but now it stops at BASE_UPD_END_USER_v25727.cav update file with the same Failed message. Also the message near the Update button states “The virus signature database is NOT up-to-date.”
What do I need to do to get Comodo to update? Go to another antivirus company?

Do you have any log links on the update screen?

In Windows it stores the virus updates in Program Data during the update I would think it would be root in Linux, there was a corrupt file 0 bytes in the Comdo folder in Program data deleting it fixed this.

Sorry do not use Comodo Antivirus.