Comodo Antivirus failing to download virus database update

I been using Comodo Antivirus for some time now without any issues with Fedora 34, but today I noticed that the virus database last updated on November 2 and when I try to start the update, I get the message “Failed to update the virus signature database. Please check your internet connection and try again later.” Can anyone help me to get this working again?

Try to add these sources under preferences → update

It worked for me

I am having the same problem as David and have also reported this to support
and was eventually sent over to the forum folks

I have been using this free Linux Antivirus for about 4 years on Linux Lite
without any issues and it stopped updating in the same time frame as reported by David

This is for Comodo Antivirus Free Version for Linux Version 1.1.268025.1

The link for this product is seen in the bottom left on the page below and is still available and downloads fine but no longer will update the AV signatures

Thank you to user Vanbosco ! - His suggestion worked like a charm

I did not notice or understand this reply before I posted my 1st reply but what he was saying was to add ( 2 ) additional download website address to the default one that comes with the product when 1st installed

The default one is this below:

I added the (2) additional addresses he suggested below to
the section : more>preferences>download as seen in his answer

After adding these alternative links my AV is now downloading fine again
Hopefully this works for everyone else also - apparently someone made a change of some type

Thank you !

Hi all,

The team has made some tweak, could you please check the DB update now and give us your feedback ?


I have been away for a week and my Linux Machine was off

Just turned back on and tried this evening 11/29 and still updating fine for me

Thank you