Comodo antivirus cannot connect to databases on startup

Each time I startup the computer, Comodo would consume too much resources (46 MB - 60 MB) and then windows pop-up would say that it cannot connect to the database. The workaround I found for this was to remove it from the delayed startup, but even then, it would still not show (probably because this time, the firewall and defense + does not work (see a previous post and yes, the firewall, too now: ). There had been no notice whether this has been looked into (as had been the case for many I’ve read and don’t ask me about which cases; it’s a foolish question to ask expecting someone to remember such petty things) and I am starting to wonder if Comodo even paid attention (thus, the double post to test if you would respond for which, thankfully[?], you did). I am very much concerned about this as I do not want to refer clients to an antivirus program that cannot provide enough protection (or more precisely, has a flaw in it) and peace of mind. !ot! I like your products, I really do (in fact, I once run cloud scanner which seemed rather pointless, system cleaner which I still use, the internet security which impressed me at first but is now becoming a pain to deal with, and the dragon browser), but I have so little time and my patience is dropping fast. !ot!

CPU (32 bit)

Operating System information (XP SP3)

Actively-running security and utility applications (WinPatrol, Threatfire, USB Disk Security)

Specific symptoms of the bug (Comodo notifies me that there is something wrong. It cannot connect to the database)

, and steps you can take to reproduce it. (It happens every startup)

Specific steps you have taken to try to resolve it. (Former workaround does not work anymore so none found yet)

Brief description of your Antivirus (Stateful mode), Defense+ (Safe Mode) and Firewall+ mode (Safe Mode)

I am using an Administrator account

Forgive me for demanding, but please help me with this dilemma. I suppose the length of my posts turns readers off? ;D

I do not know whose fault it is, but do NOT expect answers to
“Comodo antivirus cannot connect to databases on startup”

I tried but there is no Reply button.

Also please note you gave insufficient information.

You omitted the Comodo version (which I see you include in this)
and you failed to say what you mean by delayed start-up, and whether you refer to cmdagent.exe or cfp.exe.

If you are concerned about the 40 to 60 MB usage, you will not like the 100+ MB spikes when the A.V. signatures are updated.

Is it possible that something in your system is preventing Comodo from temporarily grabbing a few hundred MB - if your system is imposing an upper limit of 60 MB I suspect the database will never get updated. Reporting that as a failure to connect to the database is not quite correct, but the consequences are the same.


ah yes, of course. Forgive me for that. the version is current which is 4.1, and no, there are no other services (save for the basic ones and winpatrol) and no restrictions where made, at least not that I am aware of although the possibility is very slim and may have come from a malicious code. My current OS is XP SP3 two months since installation.

WinPatrol has a “Delay Startup” function which delays the launching of programs set to auto-start. The one I delayed is cfp.exe (it fixed the problem of the defense+ and/or the firewall not starting properly. I assume it just needs a little more time?).

But all of these had already been fixed. The workaround I found (for the firewall and defense +) was to revert back to the original theme (loved the theme by the way. was just trying out new themes) and (for the antivirus) to manually update comodo once (after which, it was fixed and the notice that it could not connect to the database no longer appears). That being said, the question now is why did those happen? Perhaps you have a guess?

I too have added delay.
I launch my own script from the Windows \ All programs \ StartUp immediately after I login in,
and I suppress all the other things which also launched at that time, and instead after suitable delays my script will launch these things. One of these things is CFP.exe.

I have found that when I update Comodo 3.? series, or even merely run Diagnostics, then Comodo will reactivate the early start-up for CFP.EXE, hence it appears in systray earlier than I want, and starts looking for A.V. updates and thus delaying everything else. Eventually my script does its thing and would launch CFP.EXE again resulting in the Comodo GUI opening on the screen - I had to use TASKLIST.EXE to determine if CFP.EXE was already running in which case my script would skip the second launch and would post a warning that CFP.EXE was back to the bad habit of an uncontrolled early startup which needed fixing again.

Perhaps you have similar aggravation with Comodo 4.? series which may be even more eager to get CFP.EXE started at the earliest opportunity.
It is also possible that when Comodo is protecting its files it may be preventing Winpatrol from causing a delay - just be thankful it does not put Winpatrol into quarantine ! !


Well, thankfully, no. I’m not having that problem with Comodo 4. O0 WinPatrol delays it well. ;D