Comodo antivirus and Firefox problem

Few days ago I started having problems with shuting down Firefox (I have version 12.0 installed). Every time I close Firefox it’s process remains active and cmdagent.exe CPU utilization jumps to 25% (basically 100% on one core, I have i5 2500K).

At first I thought it was problem with one of Firefoxes extension and tried without but that didn’t help so I tried changing CIS settings. I found out if I disable Comodo antivirus Firefox shuts down normally. I tried putting firefox.exe to exclusions list but that didn’t help.

I have latest CIS installed (5.10.228257.2253) set on proactive security and only difference to CAV settings is heuristics set to medium. None of the setting were changed in CIS since I first set CIS after last update form 5.9 to 5.10, only thing changed are daily updates and same setup was working OK a week ago.

Any suggestions what to try?

Hi HaryHr,
Try clearing all of your history in Firefox.
Include browsing and download history, cache, cookies etc.

To add to line of reasoning of captainsticks. How big is the cache size of FF set? Do you clean cache upon exit of FF?

I cleaned everything in Firefox except saved passwords with CCleaner, still same behavior. Cache size is set at default.

Firefox 13 is coming out soon, will see if that helps.

Does this also happen when FF is run without extensions?

Yes, same thing with no extension.

I have pretty much same setup on brothers computer and there it works fine, guess I’ll have to reinstall something either Firefox or CIS.

I would start with the easiest solution and that would be the browser. Don’t forget to back up your FF: Back up and restore information in Firefox profiles | Firefox Help ,

Managed to get to the root of the problem.

Problem was FlashGot extension, but not extension itself, thing that was causing problems was FlashGot log. As soon as I cleared log everything went back to normal. Guess log got malformed so it triggered Comodo or maybe got to big and Comodos script scanning kicked in.

So if anyone else encounters same behavior, you can check this also.

Tnx for suggestions and help in troubleshooting.

Thanks for posting back and sharing your findings. :slight_smile:

Hi, just to confirm I had the same problem with FlashGot that HaryHr had.
I took the easy way out and switched to another FireFox Add-On Video DownloadHelper (no problems) but after reading the ‘fix’ from HaryHr I have installed FlashGot again because I prefer it.
I went to FlashGot > Options > Advanced and ticked Log Disable
That seems to have fixed the problem but I hope Comodo will still have a look at it.
Thanks HaryHr :slight_smile:

All the best, woz of oz