Comodo and Windows 7 Backup Problems - Again

This is the second time this has happened, and again I cannot complete a windows 7 backup because of a file that COMODO flagged up and has now jammed it sideways in a Device\HarddiskVolumeShadowCopy\ folder to the point where I cannot complete a windows backup, it fails with an error just like before.

However last time it happened (same error code) it was COMODO that had flagged the file and in that case I quarantined the file and deleting the quarantine as well as deleting my saved restore points allowed the backup to complete finally, this time I did not quarrantine it, i passed it through and now theres nothing in the quarrantine to delete, ive deleted all my restore points but as before, now since this ■■■■ false positive heuristic flag up, its jammed something sideways in the HarddiskVolumeShadowCopy folder that I cannot access or delete.

Im losing the will to live trying to read about Microsoft junction points and trying to do this ■■■■ backup, it just takes so long before I can find out if its worked again, and I shouldnt be having to waste multiple hours on a problem that seems to be inherent to your scanning process - as soon as it thinks something is a virus, it seems to do something with the HarddiskVolumeShadowCopy that makes Windows 7 disconnect it.

Ive searched here and i see several hints to the same problem but rarely people reply and they are all one or two post ghost threads, I dont think people in general are this tech aware to see the signs, but obviously this is now the second time - Windows backup has worked flawlessly over the past year and as soon as I get this COMODO flag on a suspected file again, bam its down again with the same error as before.

So COMODO people, please tell me how I can get rid of this file your wonderful program has mangled? I cant even seem to be able to interact with the table to make it redetect it again. Secondly of course when will you improve the product to be compatible with W7 Backup?

Thanks for any clues, im sure ill be here for hours on this, I cant not have my backup working.


This is the table that shows the entry

still on it … backups still failing, same error, still cant seem to clear the errant file windows (with the help of comodo) mangled in the VolumeShadowCopy

If it was just the once Id be less unhappy about it, mistakes happen, but twice with a year in between? and same error and same software involved causing it.

Would be easy to blame windows but when its only happening when a comodo alert pops up and I can backup fine at all other times then obviously its something you guys should be looking at with urgency as its interrupting normal operation of my OS.

forever alone …

Well for anyone else getting a 0x81000037 error after running windows backup following COMODO doing something funky with the HarddiskVolumeShadowCopy folder during a detection this is how ive fixed it.

  • Turn off AV
    COMODO anti virus > scanner settings > slide to disabled
  • Turn off Restore Points
    Windows Control Panel > System > Advanced System Settings > System Protection
    Highlight each drive and click Configure > Turn off System Protection > OK
    repeat for each drive that appeared

    reboot pc then

    -Purge Shadow Copies
    windows control panel > Performance Information and Tools > Open Disk Cleanup
    select C drive > click ok > click more options tab
    here you can click Clean Up…Delete…to clear the System Restore and Shadow Copies for each drive
    repeat for each drive

    reboot PC again

    -Purge Restore Points
    Windows Control Panel > System > Advanced System Settings > System Protection
    Highlight each drive and click Configure > Delete…Continue > OK
    repeat for each drive - if problems can check usage is 0 after a reboot

    reboot PC again

    try Windows backup, it should complete now. if so dont forget after to re-enable restore points on the drives you turned it off on and slide your AV scanner settings slider back to stateful or on access.

Those are the exact steps I used to clear it, a bit more involved than the first time but still the same sort of thing as before

TIP if your backup is large, try running the windows backup for just your files to begin (meaning in backup settings uncheck include a system image of drives…) that should work even with the COMODO problem, and then you can enable the system image and experiment with clearing the error without having to wait multiple hours just to fail on the image.

hth and no thanks to COMODO people for the help