Comodo and uTorrent problem [Resolved]

Does anyone know how to make Comodo firewall work properly with uTorrent.
I just start to use Comodo firewall and found it an excellent. The only problem is that uTorrent is not working with it. I’ve followed eMule and bittorent tutorial, opened all required ports and still can’t get torrents green. All my torrents are red, telling me that my firewall is blocking incoming connections.
Anyone knows proper configuration for uTorrent?
Please for any suggestions.

Is it safe to assume that uTorrent was working before CPF? If so, that should indicate that your router (assuming you use one) is forwarding the ports you’ve set uTorrent to use for downloads (i.e. 6881, 6882, etc…) to you PC.

With this in tact, all you should need to do is one rule above the Block, IP In, Any, Any, Any Rule on the bottom… and is should look like the one highlighted in my screenshot attached, and also as shown below:

Permission: Allow, Protocol: TCP/IP In, Source: Any, Remote: Zone {Home Network}, Source Port: Any, Remote Port: 6881, 6882,

Note that the bottom of the screenshot shows the highlighted rules details. Also note that your ports could be configured differently than mine as I overrode the defaults for Bittorrent.

[attachment deleted by admin]

I did that what you suggest before, still the same.
Do you use uTorrent and does it work properly for you?

Myself, I use Bittorrent… but to my knowledge the torrent clients used the same base technology… but it’s possible uTorrent is a touch different.

It is explained here:,630.0.html

The bittorent tutorial works on all the torrent client (azureus, utorrent, etc.)

the correct link for bittorent tutorial is,411.0.html

just curious if you restarted uTorrent… I know my Bittorrent didn’t get all green bars until i restarted the client after updating my rules

Yes, I’ve followe them and still uTorrent doesn’t work.

It doesn’t look like all torrents are the same.

Yes, I’ve restarted it.

For the record I’m also using eMule and LimeWire and have no problem after applying ruls and opening ports, it’s just uTorrent that dosen’t work.
I’ve never had any problem using ZA or Sygate. For that reason, although I’ve found CPF a great firewall, I had to go back to Sygate.
Can’t remember where but I’ve read on the other forum that one guy had the same problem like me, that’s why I’ve asked if anyone was able to make it working with CPF.

I use both azureus and utorrent and I don’t have any problems at all.

Have you disabled the UPnP feature of utorrent? Maybe there is the problem

Also make sure “Randomize port each time µTorrent starts” is not selected.

Yes, I have.

It’s not selected.

Can you describe the rule you created in CPF?
Is it over the default block rule?

Ok, Thank you very much all of you for your help. I think I give up as for now and stick with Sygate.
Might try it again when new version will come out of beta.

Have you tried our latest beta that was out today?

I will.

I upgraded…oops sorry there is no upgrade feature…to the new Beta today, and my uTorrent is working just fine.

I’ve upgrated to new beta version and still can’t get torrents green. I have warnig sign telling me that there is no incomming connection. Here is my Network Rules. Just tell me what I’m doing wrong.

Update to the situation.
Everything is working perfect :slight_smile:
I’ve must mess up with Network and Trusted Zones. Started from the beginning and everything is fixed :smiley:
Thanks everyone who tried to help me, much appreciate. (V)