Comodo and Greenborder

Just loaded Comodo (replaced Outpost) and so far so good.
But I notice an issue when trying to run an IE7 instance within GreenBorder.

  • I don’t have Greenborder configured to start with the PC - it only runs if I start IE7.
  • Since loading Comodo, IE7 with Greenborder hangs and will not start.
  • If I stop the firewall, then IE7 with Greenborder will run normally.
  • As long as Greenborder remains resident in memory, when restarted Comodo will not run properly. The firewall starts but all the monitors are OFF and cannot be turned on.
  • I need to reboot to get rid of all the Greenborder remnants and then Comodo runs properly.

Anyone run into this?

Sounds like a software conflict.

What if you uninstall Greenborder, then reinstall it with CFP already installed?


PS: Welcome to the forums!

I am new to COMODO Firewall. I recently uninstalled ZoneAlarm and installed and set up Comodo Firewall Pro I’ve gotten my network sharing working, and I can browse the internet, but I sometimes use GreenBorder for surfin the 'net and this doesn’t work with the COMODO Firewall.
If I try to launch GreenBorder while COMODO Firewall is running, GreenBorder tries to start, but just grinds to a halt, eventually locking up and also (after considerable time) causing IE to crash.
If I close COMODO Firewall and launch GreenBorder, GreenBorder runs fine. If I leave GreenBorder running and start COMODO Firewall, the Firewall will start, but all the protections are Off, and I cannot turn them on.
I have tried adding the various GreenBorder "exe"s to the Firewall Application Monitor, and I have added the GreenBorder "dll"s to the Firewall Component Manager; but these haven’t solved the conflict.


my suggestion would still be the same at this point (as it looks like a conflict). I’d even say to uninstall both applications, then reinstall the FW, then GB, once the FW is up and running.

See what happens, and let us know…

One other thing you could try before that, just to see ~ Try switching CFP’s security level to Allow All and then surf with GB. See what happens. I don’t think it will work, but I’d be glad to be wrong. If I’m wrong, then it means we probably have a rules issue with the FW. If I’m right, then it’s back to the uninstall/reinstall routine…


First, I searched this site for “Greenborder” and did not find this previous post by jonh001 on April 13!?!

However, you (Little Mac) are quite correct… I uninstalled Greenborder and re-installed it, that didn’t work. I uninstalled Greenborder and then uninstalled Comodo Firewall, then re-installed Comodo Firewall then Greenborder and now it all works! I am surprised.

Life is good, and seeking out this forum was well worth the effort. :■■■■

Thanks Little Mac.

That’s alright. The search function isn’t working properly. (I had to use the Advanced Search’s ‘topic subjects only’ option with the key word “border” to find this one). I moved your post here ;).

General tip as LM had pointed out: Firewall should be installed prior to other security software. If not, at least try to disable the other security during CFP’s installation to avoid potential conflicts.

You’re welcome, waray; I’m glad it worked!

Even tho it would seem that simply redoing the one app would do the trick, in my experience, once there’s been a conflict, you almost have to reinstall both apps, and in the reverse order. And as Soya pointed out, with security apps, the FW is generally best installed first.

Jonh001, I’d love to hear how yours has worked out… If you would give us an update, that would be great!