COMODO and Firefox

I have Ver. 3 and tried to update FF to It locked up my computer. I booted to my secondary snapshot[FDISR] . Then I updated my primary from the secondary and tried again. Locked it again. I finally exited Comodo then it downloaded. I just wanted people to be careful.

you seem to be having a lot of problem with v3. it would be interesting to investigate why. it sounds as if there is some stuff on your machine that doesn’t agree with v3 (or vice versa) (could be malware or some other security software). But the problems you are having are not normal, hence worth investigating.


… Please give us more details, like system, other programs, if you have explicitly disabled any services etc.


I think that I may know the problem. I have SSM Pro. on my machine. I know that I’m not supposed to . That is why I am running the Firewall with Leak protection. I have a lifetime license for SSM and at this time would rather keep it. But I love Comodo and other than this one problem,there hasn’t been any other issues. I will just have to remember to exit one or the other before installing something.

that would explain it thanks. these kind of hips/firewall programs hook the hell out of kernel for protection and they will fight and cause unstability if used together. Leak protection in v3 does use part of the hips. If you really want to use ssm, then use cpf simple firewall with no leak protection.


With all due respects to firefox which I mainly use as a browser, its has given me quite a few fits on updating. So firefox is a poor diagnostic to gage comodo problems from my past experience.

I used to have constant problems updating fire fox and seamonkey, but that I think was due to a conflict with a version of Java. The long and the short of it is that the firefox programmers and java programmers got the problem resolved with the later java versions.

But if I have firefox upgrade installation problems, the first thing I do is to go into Windows safe mode with networking and then the firefox and seamonkey upgrades seem to go off without a hitch.

But in terms of SSM and and CPF3 conflicting, it may take some personal experimentation to see exactly what configurations of SSM might be possible and still be able to run CPF3 and D+ without conflict. Its been a very long time since I tried and subsequently quit using SSM. So I can’t remember all the configuration options in SSM.