Comodo alpha Uninstallation Cleaner [CLOSED]

Some people encountered problems when they try to uninstall/reinstall comodo Firewall Pro Alpha on their computer (windows xp). So I decided to make a little batch to completely remove registry entries and folders of Comodo. (Launch it after uninstallation!).

I had problems with Comodo Uninstallation also. I solved it with the recovery point setting.


Thanks sogno, will give that a try on my next uninstall.


Thanks for that, but isn’t this line **** start /w regedit /s Files\remove.reg *** only going to work if they have a file called REMOVE.REG in a folder called FILES?

Ewen :slight_smile:


Yes, it’s right… And this folder is packed with this archive ^^. So I don’t understand the trouble :slight_smile:


I have the same problem.the cleaner doesn’t fix it the only solution is a rollback…

I have vista32

    Thank you for the informaton  I've been trying to uninstall the older version for a month  thank you  and God Bless You!

will this batch file also help fully remove the current 2.4 version of CPF? one of the problems i have encountered is that if i ever need to uninstall and reinstall it, the windows xp security center never reverts to normal…it always shows comodo as present even after it has been uninstalled.

No, it has no connection to v2.4, on v3…

This is an issue related to the way that WSC works; it is keeping information on the firewall present after uninstall. This does not mean the firewall wasn’t uninstalled successfully; it means that WSC is well, basically useless… :wink:

See this thread about rebuilding the WBEM repository - this is where the issue is…,2479.msg19751.html#msg19751


thank you for reminding me about that batch file. btw…as an addendum, i have tried several other software firewalls, and i always end up back with comodo! what can i say…it remains the best there is.

what link do i need to use? there’s two link here very confusing.

i’m using vista 32.


If you’re using vista 32, then your only firewall option (from Comodo) is v3.0.2.5 Alpha. Thus, the “uninstallation cleaner” is available from the link in the first post in this topic (by sogno).

The link I gave Philbee is regarding Windows Security Center (WSC) and rebuilding its repository so that it would stop showing CFP v2.4 as being installed, after that version of the FW was uninstalled.

Hope that clears it up.


BTW, I’ve moved this topic to the new v3 boards.


Btw, after i installed my comodo its not showing in my security center.
I uninstall KIS and use one the link here given by mods to erase KIS at security center…but my problem now is comodo is not showing in my security center.

Right. CFP v3 Alpha will not show in WSC. Windows will not recognize any non-production product (ie, an Alpha, Beta, or other testing release). In fact in some cases, it won’t recognize final release products either; it has to be coded into WSC by Microsoft, and until they get around to it, it won’t be recognized. Not a cause for concern.



Maybe it would be easy to update your cmd file with “reg delete” commands ;). Does the reg file need “-” tags?