Comodo 8.0 HIPS not working properly.

I’ve been running this setup for a while and I never had any problems. Proactive Security active, Auto-Sandbox disabled, HIPS in Safe Mode everything in default, Firewall set to Custom Ruleset with alert frequency level set to medium.

Ever since I upgraded to version 8 the HIPS function doesn’t seem as aggressive or responsive like in the previous versions. I ran a couple of tests in virtual environment with the same setup. I was notice the Firewall was the one doing all the blocking with Block, Terminate and Reverse or Block and Terminate. Nothing from the HIPS side. Even when I let malware samples access past the Firewall I got no alerts from the HIPS function.

I’m having a hard time troubleshooting this problem. I don’t know if this is a bug in the software or something I need to set in version 8.

Does COMODO Internet Security 8 vs Malware Tests shed a light on your situation?

Then there has be to something with this new version then. Because the HIPS feature in safe mode is not working properly. For time being I reverted back 7.0. Unless there is a way to make HIPS as it was in the previous version. I’m not touching 8.0 at all.

Edit: Miss spell. :embarassed:

Do you have Do NOT show pop up alerts disabled?

Always kept it unchecked.

As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

Do you have other security program(s) running in the background alongside CIS? What happens if you temporarily disable or uninstall them?

Sorry for the late response. Even under a clean install I still had the same problem. I’ve been running Kaspersky anti-virus with Comodo firewall for a while with no issues.

Do you mean KAV was completely uninstalled using the Kaspersky clean up tool? Then the problem is somewhere else.