Comodo 3 vista ignoring my rules.


Just installed Comodo Firewall 3 Alpha for Vista. Seems to be working great. not had any major problems so far. However it is blocking incoming requests to connect to my WinSSHD server which is listening on port 22.

I’ve added the SSH’s windows service (.exe) into the security policy as a “Trusted Application” but its still blocking the request on the port.

I’m having trouble finding out where you open and close ports. I’ve found a ports set list where you can group ports into custom catergories but thats all.


Ok Looking in the firewall logs I get this:

Application: System Idle Process
Action: Blocked
Protocol: TCP
Source IP: My External IP. Won’t put here for security reasons
Source Port: 54501
Destination I.P: (My Router is forwarding the request to the correct computer)
Destination Port: 22 (Correct also)

Since it claimed it was the system idle process I setup a rule as follows:

Network Security Policy > Add > Select Running Process > “System Idle Process” > Select.

Use Custom Rule Set > Add

Source Address > Any
Distination Address > Single IP >
Source Port > Any
Distination Port > 22 > OK


Tried again and still blocks it. is this a bug or am I doing something wrong?

I even put an alert on it so it would inform me when the rule is acted upon. and I never got an alert.

— As a final resort is there anyway to switch off port blocking etc… and just use the program control? My Router is good enough on the ports side of things.

JUST add a rule in the “Network Security Policy ->Global Rules” to open your port 22…

but that doesnt answer why my rule doesnt work.

never the less I tried what you said and did a global rule to open 22 on any i.p, source and destination… still doesnt work… still blocks anything to do with 22.

Make sure Vista’s firewall is off.

Welcome to the forums RiGoRmOrTiS

Remember you are dealing with an Alpha Release but I know there are some people who have network rules working on Vista. and I have it working on XP and on Vista in a VM

you should only have port 22 as the destination Port the source port should be any like you had in your example except in your global rules this should work
Source Address > Any
Distination Address > Single IP >
Source Port > Any
Destination Port > 22 > OK

Make sure this rule is on top of any blocking rules

and as was suggested make sure Vistas firewall is disabled

If that does not work delete the rule you added to Application Rules.To access or leave you PC traffic first must match a Global Rule then there must be an application rule to allow access to an application. If you are trying to filter application traffic at the Application level it can get very complicated. but it is possible.

hope this works