Commodo Suddenly Blocking PLEX

I recently upgraded my router (from an ASUS RT-88U to an ASUS GT-AX11000) and had to enable port forwarding on the router (port 32400). However, I cannot connect to the Plex Media Server now, unless Comodo is turned off. ALL of the PLEX executables are allowed and PLEX is set as a TRUSTED vendor.

I have also disabled all of the (Firewall) ADVANCED options (Filter Loopback, Block Fragmented, etc).

Windows Firewall has no effect on or off - only Comodo.

Any ideas? Thanks.

(I hate to run my system without Comodo)

Port forward in Comodo too. Global rules are processed first for incoming traffic and need a matching listening application or windows will discard the pack.

You need to allowing incoming traffic on 32400 TCP or UDP whatever it is in global rules.

Yes, already did that - no effect.

Set both Source and Destination ports to 32400 and set at the top of the list (for both TCP & UDP)

Also set it for all combinations of 32400 and Any Port.

Hello DeathStalker77,

Thank you for reporting.We are checking in it.
Have a nice day!

Kind Regards,

Many thanks :slight_smile:

You may need to port forward more than just that one port.

TCP port 32400 for the Plex Media Server.
UDP port 1900 for the Plex DLNA Server.
TCP port 3005 for Plex Companion.
UDP port 5353 for network discovery.
TCP port 8324 for Roku via Plex Companion.
UDP port 32410, 32412, 32413, 32414 for network discovery.
TCP port 32469 for the Plex DLNA Server.

Taken from a TechJunkie article on Plex and the ports it uses for streaming - What Port does Plex Media Server Use to Stream?

Hope this helps,
Ewen :slight_smile:

OK, will try adding those and let you know what happens :slight_smile:

Nope, no luck - added every single one of them to the router and still it will not connect with Comodo enabled. It would be nice if you were able to get a GT-AX11000 and test it (or someone else who has one).


You need to make sure Windows firewall is disabled across all network types home/public/work, and the allow global rules need to have the source port set to any while the destination port set to the specific port number. And both source and destination address should also be set to any. You can try adding the server executable to dont detect shellcode injections exclusions, but make sure you either restart the application or add to exclusions while the service is not running.

Again - it stream PERFECTLY with Comodo disabled and Windows Firewall ENABLED. So that is NOT the issue.

Hey DeathStalker77,

Have you also added those ports in Comodo Firewalls Global Rules?

How is this blockage reported in the firewalls logs? Or is it not being reported?

Ewen :slight_smile:

I added the Port 32400 to the firewall, but not all of the others. No log entries.

Well holy crud - if you go to the Global Settings and for the Destination port and select A Range Of Ports - there is specifically an option for PLEX!!! Enabling that resolves the problem!!! :smiley:

Well, we ended up where we intended, just not how we intended.

In the words of Mark Twain, “■■■■ the thoery if the machinery works.”.

All’s well that ends well.

Ewen :slight_smile: