Commodo application agent is not running... AT RISK

:embarassed: I thought I had saved and had noted which services I had turned off but it seems i did not save this txt doc and now I cannot undo or turn back on service which is causing problem.
I cannot resort to looking at event log as I have that service turned off too and am kicking self as it is dumb to not have made certain.
At this time of tweaking system I turned off ‘DCOM Server Process Launcher’ which is now disabled. That is one i know for certain. I have not tried turning this back on as this is a tweak i have done before (though not with commodo) as i have been led to believe its unnecessary and even insecure to some extent and never had issues with this before.
I did not trouble off any commodo services other than updater for dragon browser which i put to manual & geek buddy which initially i disabled but then put on manual as well.
It is a windows service which is causing my problem and i wondered if anyone would know one or any that is definitely required for commodo application to run properly. Everything else is fine on computer. I have just noticed though that realtime protection is active though the red I see in app agent and widget is worrying. the FIX IT button in red does not solve issue either but i didn’t think it would if i disabled a service needed.
I would greatly appreciate any help the forum could give me.
I am running windows XP home which i should have stated at begin…

Hi and welcome DoveKlaw,
The only listed dependency is ‘Remote Procedure Call’.

I would suggest re-enabling the event log service and reboot the system to see if any logs can help determine the error.

I also recommend setting all services back to default and see if the problem is resolved.
If it is resolved, then use more caution about which services you disable and even make a hand written list.
Black Viper’s Windows XP x86 (32-bit) Service Pack 3 Service Configurations

Hope this helps.

Edit: I just tried my XP with the ‘DCOM Server Process Launcher’ service disabled and it did not stop the cmdAgent from starting, but it did interfere with the Antivirus Database & updates.
I would personally recommend leaving this service enabled.

Thanks very much for your help and advice captainsticks.

I will do as you have suggested and the Black Viper service configuration list is and will be a great help i’m sure.

Much thanks bruv…

You are welcome, I hope you get it sorted out. :slight_smile: