COM Surrogate has stopped working

Since yesterday, updating to the latest Windows 10 Creators Update, every time now I open my start menu I get this error message that pops up;

I was on CFW v10, when I uninstalled it the error message went away, I tried going back to v8.4 to see if it was a v10 bug but the same “COM Surrogate has stopped working” message would pop up too, it again went away after I uninstalled CFW.

Is there a fix for this? Can anyone else reproduce? Seems this user also had COM Surrogate issues.;msg855119#msg855119

As far as I can determine, it’s a Windows Creator problem involving supposedly / possibly out of date display drivers. I tried a few fixes but nothing worked. I don’t think it was anythign to do with CIS etc. as it was still present after I’d uninstalled

Once I did a Creator rollback, all was back to normal with CIS running fine

Well I’m on the latest NVIDIA Geforce 381.65 drivers that were released a few days ago, also use a Nvidia 1060 which is a modern popular card, I would image my setup is not that unique and many would be having this issue.

I’m not sure what COM Surrogate is exactly, I’ve Googled some, and I’m finding posts about Network drivers, llike so;

Could it be a Comodo Firewall driver bug?

I wonder if you uninstall CIS and reboot then update w10 to the creators update, then install CIS to see if that would help with this and the text display issue you said you experienced before.

When you uninstall CFW is the firewwall driver still listed in your network adapter properties? You can try to perform a clean uninstall using this removal tool. Use right-click run as administrator choose option to remove CIS, reboot when it completes and then install CFW again.

Its a default ‘sacrifical process’ to stop explorer crashing! There’s asome info here How to Fix COM Surrogate Has Stopped Working In Windows 10

I’ve also got the latest and greatest in drivers and system(s) but it still appeared with Creator. Your guess is as good as mine so far . . . .

Hi futuretech - I tried all that yesterday with and without CIS in Creator. The end result was Creator still gave the COM surrogate error without CIS

After all the adventures, I explored Creator and decided I didn’t want it and rolled back. Umesh is apparently looking into it and come the next CIS update, I may plunge back into it again :wink:

Worth mentioning these are the Event Viewer errors that pop on when it happens.

I saw similar when I checked, but couldn’t get much further. I just love those indecipherable messages - that’s why I went for the stiff drink 88)

Please check again with version thanks.

Somehow I knew you’d ask that 88)
Ok - but give me a few hours to prepare for yet another Creator rollback

With a clean install of CIS & ISE added, everything is fine with the Creators build. (I had updated Win10 seperately, with all the MS updates prior to Creator if that may have had any effect)

There are no errors, text is fine, Start menu & tiles as I left them and CIS etc. are doing what they do best with updates, settings, lists and functions as should be

Excellent bit of work ;D