CMS updates

I have a Samsung Galaxy Ace 2 using CMS. Every time I check for updates it says one is available, downloads it and says it is installed. However if come out of CMC then back in and check again it again says an update is still available. When I check the virus database version number it always says vers. 93.

I have no confidence that CMS is actually protecting my phone. My partner’s Ace (not Ace 2) also has the same problem. Any idea if this will be fixed?

Which version are you running? This was an issue prior to the latest thought I can’t recall if it was a server issue rather than a software one.

Don’t worry though .93 is the latest signature and will have been applied at the first time you downloaded it.


I’ve done some tests and can confirm I’m also experiencing this issue.

Devs, can you advise if this is a server update issue or software related?


[EDIT]: Strangely it may be limited to only happening once after you reboot your device. After you click Yes and re-download the update and check again it seems to resolve the issue on my android at least. Further testing revealed that this is the case every time you restart it. *You do get the “Up To Date” flash message before you re-download the signature.

@Tinman9898 - Can you confirm this is the same on your device?



I have the same problem with Nexus4 :frowning:

Confirmed. This seems to be a bug even with the Play store version. With the previous forum version all I got was Update Failed. I’ll PM the devs.


thx Eric :slight_smile:

Should be resolved now. After talking with Herbzhang I’ve successfully updated to Signature v 94 on my phone. You still get a “update failed” message if you check for further updates but I’ve advised him to see about getting that message to instead indicate that your up-to-date.

Let me know if any of you have any further issues.


We are analyzing this “Update failed” problem and its business impact. We will issue a new build with fix of it next week if necessary.


I downloaded the new update. It\s still not working. It gets to about 60% of the update and then I receive the update failed error message.

fixed, thx\

hi minacross,

it seens that the issue comes back again.

each time when i update virus database, it tell me ‘there is new version’, so i click yes to update, but i was always told update failure.

right now my CMS is 2.2.288243.73 with virus database version 94.0.

Ppazq, my app version is 2.2.288243.74, and my virus definition database is 95.0.
Update tells me everything up to date, no updates available.

DL the latest version and install it. Your issue should be resolved with this release.

hi John, thank you for the replay.

the Current Version shown in Google Play is still 2.2.288243.73, any where else I can download or update to 2.2.288243.74 ?

I found a download link of cms_android_forum.apk from Important Topics. Is this package always synced with Google Play?

And by the way, I think it is helpful to write the number of latest version of CMS and it virus database on this forum or on the