cmdagent & Windows\Temp directory


This is probably related to other problems posted here regarding Version 5 (1142)

I upgraded to version 5 a couple of days ago and all seemed fine, however this evening I have encountered a problem when running Ccleaner (2.36. xxxxx)

I am running this on a fully patched Vista SP2 laptop.

When I run Ccleaner it causes cmdagent.exe to max out the cpu and Ccleaner hangs when accessing files in the Temp directory (Windows\Temp). I first thought it had something to do with some CAVxxxx.tmp files as this was the file name it displayed as it hung. However, after managing to get revo uninstaller to delete them it became apparent this was a red herring (even though revo took about 20 secs to delete each of the CAVxxxxx.tmp files).

I ran ccleaner and it hung again in same place with cmdagent again maxing out the cpu.

I ran Ccleaner without temporary files selected and it ran through in seconds.

I deleted the remaining file/folders from the temporary file folder using explorer and ran Ccleaner yet again - and it hung again with cmdagent again maxing the cpu.

CCleaner played happily with version 4!

Further info.

I ran the same versions of Ccleaner and CIS on an XP SP3 box and while cmdagent used quite a bit of cpu other processes were able to run and the system remained responsive even while ccleaner was clearining up Windows\Temp files.

Back on the laptop however, I ran a CAV scan on the system and when the scan got to the windows\Temp files the scan ground to a halt taking up to 30 seconds to process.

I created a scan profile this morning that just included Windows\Temp directory. After the scan raced through scanning running processes etc it again slowed to a crawl on the files in the Temp directory with cmdagent grabbing all available cpu - as I write this it’s between 96-99% with lowest 94%

I left it running and it took 103 minutes to scan 838 files, however the 390 files in Windows\Temp took 101 minutes of that time!!!

I’m having similar problems with CIS in my Windows 7 (32bits) machine, takes all the free space in my windows/temp folder (around 20G) with CB****.tmp files of around 80M, I’m just updating to the newest version right now to see if it solves the problem.

best regards

PS: you guys make an awesome antivirus/firewall

PSS: I’m running the updated 5.0.163652.1142 version now, deleted all the temporal files and I will report back in a couple of hours

With the new version the bug is gone. I finally can use my computer normally.


I’m apparently having the same problem, but I don’t think it’s related to Ccleaner. I’m running WinXP SP3 on a pc with an ASUS M3N78 motherboard & a 2.20ghz AMD Phenom 9500 Quad-core processor w/4gb ram.

(I did have the problem described above with Ccleaner after the automatic upgrade to Comodo v5, and was unable to get past that until I rebooted into Safe Mode to delete the offending temp files. Since then, Cleaner has been fine.)

On startup, cmdagent consumes all or nearly all of the cpu for several minutes, and the majority of it for some time after that. I read the previous posts & downloaded & installed the current version (5.0.163652.1142) which turns out to be what I was already running.

The problem persists. I completed the install & virus definition update (complete with a couple of warm-boots). Then, I turned the pc off for 5 minutes. On turning it back on, cmdagent again consumed all or nearly all of the cpu for several minutes, and bounced around between 50%-75% usage for more than 20 minutes. Since then (another 30 minutes) it’s been bouncing between 25%-50%, with occasional jumps to 75%.

Is there an explanation for this? Or a cure?

(I have Project Lasso v3.84.3 in the system tray monitoring system usage, but throughout this morning I’ve also had Windows Task Manager open so I can see the details I wrote about above.)

I recently saw a user reporting that updating CCleaner to the latest v3 solved the problem.

I have never found anything of any value in any of the temp folders. To that effect I have a script that I’ve named DelTemp.bat and lives in the root of %SystemDrive%:

RD /S /q “C:\Documents and Settings[UserName]\Local Settings\Temp”
RD /S /q “C:\Windows\Temp”
MD “C:\Documents and Settings[UserName]\Local Settings\Temp”
MD “C:\Windows\Temp”

I’ve included this script as a startup item in Computer Settings under Windows settings via the group policy editor (gpedit.msc). That certainly would seem to solve 20GB (!!!) of some of your problems.

Your syntax seems to be incorrect, as you delete temp files for the current user while creating them for the administrator, for whom they have not been deleted.

Also note that, without specific policies, a simple trick allows NT systems to run autoexec.bat like Win9X did.

Oh, I see how ya are.

There fixed it. Of course for multi-user systems you’ll need to duplicate the entries for each valid user.

Why resort to legacy technology when group policy objects are the cat’s pajamas? That’s like using a standard modal form instead of a shared class. What’s up with that?

No other comment, and nothing wrong with it (excepting that i am not sure that Windows Home users can manipulate group policies as far as they could want).

I only made the observation because more and more people don’t even know what bat or cmd are:
someone could have used your syntax litterally.

Oh, yes, a related comment: as i don’t use IE, i was very lazy and tried to get rid of Temporary Internet Files (still written from local actions) by setting it “read only”.
You know what? Windows creates another instance of the beast in Temp: in such an instance, it is therefore be useful to add to such a script the same action for T.I.F.

Coming back to the topic, most softwares (i don’t use Ccleaner) have some option to customize or wipe their temp files, but probably of course not relevant to the CIS CPU bug.