Cmdagent not started error (but it was) before initial reboot [V6][M187]


  1. What you did: Did a clean install of comodo firewall. After the installer completes nothing seems to happen. I looked in the task manager and saw that cistray.exe and cmdagent.exe were running. after about 10 minutes i get an error (screenshot attached) then it asks if i want to run the diagnostics (report attached)
  2. What actually happened or you actually saw: comodo firewall seemed to install properly but it cant start without an initial reboot. After running the diagnostics like comodo asked me to, it didnt find any problems.
  3. What you expected to happen or see: i expected the GUI to appear and ask me for a reboot.
  4. How you tried to fix it & what happened: Tried to reintall, making sure all traces were removed. this did not help.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: i dont think its a compatibility issue.
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Everytime i do a clean install of comodo firewall or internet security i receive this error.
  8. Any other information (eg your guess regarding the cause, with reasons): My computer is the only time iv seen this happen so idk whats going on. i dont really have much running in the background and dont have any other security apps installed.

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Report attached after the error occured.

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: Screenshot attached of process hacker since comodo wasnt fully installed yet. I took the screenshots before the initial reboot.
  2. Screenshots illustrating the bug: Screenshot attached of the error comodo displayed
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: Attached
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Attached


  1. CIS version, AV database version & configuration: screenshot attached of about screen
  2. a) Have you updated (without uninstall) from a previous version of CIS: No clean install
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Default settings; firewall config
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: d+ disabled; firewall safe mode; BB disabled;
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 ultimate x32; sp1; UAC disabled; admin
  7. Other security and utility software currently installed: peerblock on demand. loginpro but this reproduced when loginpro was not installed.
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: N/A

[attachment deleted by admin]

I had the same symtoms, same message, though Cmdagent running, albeit after using CIS 6.0 for a few days. Do you have CBU Beta 2 installed?

May be worth taking a cmdagent dump and a CBU dump. I could not take the latter.

If so Uninstall CBU beta 2, reboot, uninstall CIS, reboot, reinstall CIS and you should be OK. Don’t use forced installer it may have caused problems.

System restore did not work for me. Wierd.

Best wishes


yes i have cbu beta 2 installed but the thing is i have had this problem since beta 1 of cis v6 just never got around to do a reinstall and collecting the info for a bug report. i was hoping it would have been fixed but it never did so i finally decided to do a clean reinstall and collect the info for this report.

when i say i do a clean install i use revo free, comodos built in uninstaller runs without problems then i delete the leftovers with revo then manually go through my hard drive and delete any more leftovers which usually isnt much. i dont go through the registry manually and i use caution with revos scan results

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


not fixed in 2708. i have attached the new diagnostics file and created a dump file of cmdagent.exe after the error

Dump file download

[attachment deleted by admin]

Tracker updated

NOT fixed in CIS 6.1.275152.2801

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

This is NOT fixed in v6.2.282872.2847

Thank you.

I have updated the tracker.

This is NOT fixed in v6.3.294583.2937

Tracker has been updated

Thank you.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

i am no longer using the computer that was affected by this. I havent seen anyone else report this issue so lets call this resolved.

Thank you. I have now closed this entry in the tracker and will move this report to Resolved.

Thanks again.