cmdagent.exe is delaying apps from loading

If cmdagent.exe doesn’t have internet access, when opening (especially) an unsigned executable, cmdagent.exe tries to send about 6 requests to an external IP, with a delay between them of about 2 seconds. As a result, the opening of the app is delayed for about 12-15 seconds. This is very annoying. File Rating is turned off.
Consecutive openings of the app happens instantaneous; but after a couple of days, maybe a few restarts, the delay happens again.

  • Windows 10 x64
  • Comodo Firewall
  • How you tried to resolve the problem - File Rating is turned off, but to no avail.

Hello velurrel, cmdagent.exe stands for COMODO Internet Security Agent, it a service from Comodo internet security and from my knowledge it monitors applications and checks them in CIS data base, i will forward this post so CIS moderators can help you further. This a Comodo Ice Dragon Topic (our browser).

Hello velurrel,

Thank you for reporting.We will check this.
Let me know your CF version Please?

Please let me know the name of the software which are you mentioning here?

Kind Regards,

Comodo Firewall
Software - any app is being recurrently frozen - Firefox, AIMP, Vivaldi browser, Chrome. Very often - Nirsoft WakeMeOnLan

I’ve said that too many times.

Comodo insists on ruining everything good in CFW.

What’s the point of having a setting to disable network lookups if it doesn’t disable network lookups!

Pleassssssssssssssssssse add a new OFFLINE MODE at least for Comodo Firewall.

We don’t ( all ) need cmdagent to scan every file we launch!

Hello velurrel,

Thank you for your response.let me check this issue and notify you.

Kind Regards,

One of last version to work normally was
First version I encountered the issue and reproduced it -

sorry inconvenience… :-
Acess: Internet Security Software Main Interface | Internet Security Help | COMODO
in help window click in diagnostics, if error in installation…
Try reinstall:
comodo uninstall:

follow the instructions comodo uninstall and then install CIS.

NOTE(companies softwares): windows update as it updates its versions, over time it corrupts security programs like suites, antivirus, games with anticheater …

sorry my english!

All of the bugs I mentioned were encountered on a clean Windows, fresh-installed.
Including these 2, I tested separately, on a clean Windows virtual machine:
Version is working normally.
Oldest version to reproduce the issue - All version after it are affected.

It is not a bug when you block CIS process from functioning properly, and the apps you listed are in fact digitally signed with a digital signature, which means CIS was attempting to check the validity of the digital signature. If the application is not signed then this check does not happen, and this check is independent of file lookup so disabling file lookup will have no affect with certificate revocation checking.

Thanks for the explanation.
How to disable certificate revocation checking? It’s not normal almost every time I open an app for comodo to check something.

You can’t it is hard-coded into CIS, you can try disabling Rate applications according to their vendor rating in file rating settings. Btw, this isn’t something special that only applies to CIS, Windows also does certificate revocation checks of signed applications when they are executed.

“you can try disabling Rate applications according to their vendor rating” - it was already disabled.

“Windows also does certificate revocation checks of signed applications when they are executed” - If you mean Windows Defender - maybe, It’s disabled on my machines.
Otherwise, Windows executables are also blocked by Comodo\Firewall, and no issues experienced.

I think Comodo should be flexible enough to allow to disable certificate revocation checking.

Hello velurrel,

Could you please share me if you are still facing this issue?
Have a nice day!

Kind Regards,

Hi. Yes. Especially with nirsoft wakeuponlan. Almost every launch of it is blocked for 10 seconds.

Hello velurrel,

Thank you for your response.Let me check with that product and update you.
Have a nice day!

Kind Regards,

I’d like to add my experiences, too. I updated 5 computers for my family from CIS to the latest CIS
Every computer shows the identic symptoms. Starting any app takes now 3 or more seconds now. Starting Firefox, Chrome or WinRAR takes even longer. For example, right-click on a RAR archive and selecting “extract here” takes over 10 seconds till WinRAR starts extracting.

Also tested on fresh installed Win10 1909 x64 and Win10 2004 x64. No other apps installed. Tried to start the following portable apps: Firefox, Chrome, Media Player Classic, Media Player Black Edition, VLC Media Player, WinRAR, 7-Zip, Aida64, Teamviewer, NirLauncher. It took moren than 3 seconds or longer until any of those apps started. With CIS this behaviour never happened. Apps started right away.

Please fix this or give us at least the option to deactivate the Comodo check running in the background.

Is there any security reason to keep on using CIS for my family? We only use the Firewall and HIPS.

Thank you and stay safe.

Maybe stop blocking network access for cmdagent and you wouldn’t have such issues. There is no reason to block OSCP revocation checking, even Windows performs this check when launching digitally signed applications.

“Maybe stop blocking network access for cmdagent and you wouldn’t have such issues” - I tested with a slow network. It also introduces some significant delay (because cmdagent waits for a response). Which makes this bug more serious than I thought.
“even Windows performs this check” - Windows (svchost, explorer.exe, etc.) is also blocked, with comodo firewall. Such delays don’t occur.

This bug is more bad than initially thought - if the apps are opened from start menu, the whole taskbar, start menu are blocked/frozen (Windows 10 1903). Windows 10 1909 restarts the taskbar. (I’m not sure if 1909 has taskbar hosted in a separate process, or it kills and starts explorer.exe, which is worse).

Well At Least I Tried. ¯_(ツ)_/¯