Cloud Antivirus Removal

Can someone help to get rid of the Comodo Cloud Antivirus malware ??
It got installed when I installed the Icedragon browser and now I can’t get rid of it
(yes, I have tried the normal uninstall procedure but as usual with some of comodo’s products, it doesn’t work)…
After trying to uninstall this I am left with a running program, in the background, that I cant get rid of nor can I shut it down or remove it from services,
so any and all help with this matter is appreciated (would hate to have to wipe my systemdrive and reinstall windows 10 just for this)

I just used revo uninstaller:

  • open the program (downloading as freeware)

  • choose ‘application’ and look for comodo/cloud …

  • click on with the right mouse buuton

  • choose ‘intensiv’ instead of ‘deinstall’ into the opening menu

attachments: example IceDragon

Hope that Revo will work since Cloud Antivirus deosn’t show up under installed programs any moore…
Will try and see, thx for the tip

Tried Revo and it doesn’t work, Revo can’t find the application to remove …

Then try to click on deinstall and then “install” with revo uninstaller once more and then repeat as I wrote. So revo knows what is installed, I think.
So did I this. Hope, it will help.


  1. Click on ‘deinstall’ in revo
  2. click on ‘install’ (installieren)
  3. start your computer
  4. same procedure: revo-look for cloud…, r.m.button- click on ‘look for’ (‘durchsuchen’)
  5. click on ‘l?schen’ = delete
  6. once more delete

then it is removed from your pc!

Tip: Cloud Antivirus is not malware.
It is a legitimate product (now discontinued) from a legitimate company.
If you act politely and respectful, more people will try to help you with your problem.
One attract the bees with honey and not by using vinegar.

If you have trouble deleting Locked Files from your computer, try Smart File Delete from NVT.

If you can’t remove a legacy registry key related to Comodo products, use Registry DeleteEx.

At first glance I thought the same thing, but I think he means this as part of the name: ccav (m), ccav as a search for malware.

Well, I did, finally, get rid of this program to some degree.
Did a safe mode reboot and got all the files related deleted (I know it’s not a good solution).
So now I don’t have the issue with this running anymore.
thx for helping out

When a program behaves like this then I feel it’s warranted to categorise it as malware, just my opinion, no honey or vinegar needed :slight_smile:

It’s good that your problem was solved.
About this behavior from security applications, this is quite common since almost all AV software use hooking techniques commonly used by Malware so they can’t get killed that easily by threats that try to deactivate AV, etc. This is true to all security vendors and if you can’t deal with this then use Linux or other OS.